Bug 1271985 - [devexp_public_692]Build fails if build time exceeds defined completionDeadlineSeconds even build is in running state
[devexp_public_692]Build fails if build time exceeds defined completionDeadli...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Build (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Maciej Szulik
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 04:40 EDT by Wenjing Zheng
Modified: 2015-11-23 16:13 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:13:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2015-10-15 04:40:30 EDT
Description of problem:
When completionDeadlineSeconds to a small number in buildconfig,build get failed even it is in running state.

Version-Release number of selected component (if applicable):
openshift v1.0.6-610-g1bc373b
kubernetes v1.1.0-alpha.1-653-g86b4e77

How reproducible:
always

Steps to Reproduce:
1. Add below setting to buildconfig part
"spec":{
        "completionDeadlineSeconds": 30,
        
2. Create build with it
3. Check build status

Actual results:
Build get failed even it is in normal running state.

Expected results:
This value should be only work when build keeps pending.

Additional info:
Comment 1 Ben Parees 2015-10-18 21:25:47 EDT
The completiondeadline is a maximum duration for the build to reach a "complete" state, so it is expected that it would go from "running" to "failed" if the time is exceeded.

Is there something in the documentation that lead you to think the build should not be failed?  I'm going to set this back to ON_QA but if the documentation is wrong, please reopen and we'll get the docs fixed.
Comment 2 Wenjing Zheng 2015-10-18 23:03:52 EDT
Thanks for your confirm, Ben! Since the card says for pending build, so report this bug, just checked documentation carefully, it has no issue. Will verify this bug.
$openshift version
openshift v1.0.6-691-g3d79bc3
kubernetes v1.1.0-alpha.1-653-g86b4e77
etcd 2.1.2

Note You need to log in before you can comment on or make changes to this bug.