Bug 127201 - Upgrade RH9 -> FC2 breaks GLX with NVIDIA card
Upgrade RH9 -> FC2 breaks GLX with NVIDIA card
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-03 16:29 EDT by Dan Reish
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-04 04:02:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Reish 2004-07-03 16:29:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Attempting to run anything that uses GLX, such as
/usr/X11R6/lib/xscreensaver/glmatrix, produces an error message:

Xlib:  extension "GLX" missing on display ":0.0".
[repeats several times]
glmatrix: display ":0.0" does not support the GLX extension.

This is unfortunate, because my card did pretty fast GL under Red Hat
9.  (Brief log excerpt at the end of this text.)


Version-Release number of selected component (if applicable):
xorg-x11-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1. Upgrade a RH9 system with an NVIDIA card to Fedora Core 2
2. Try to run a screensaver


Actual Results:  Error message

Expected Results:  Should see pretty pictures

Additional info:

From /var/log/gdm/:0.log

(==) Using config file: "/etc/X11/XF86Config"
Symbol __glXActiveScreens from module
/usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXActiveScreens from module
/usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
(EE) [GLX]: Failed to add GLX extension (NVIDIA XFree86 driver not found)
Comment 1 Dan Reish 2004-07-03 23:19:03 EDT
I tried running:

nvidia-installer -a --update

It ran successfully but there was no improvement.

Symbol __glXActiveScreens from module
/usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
Symbol __glXActiveScreens from module
/usr/X11R6/lib/modules/extensions/libdri.a is unresolved!
(EE) Failed to initialize GLX extension (NVIDIA X driver not found)

Xlib:  extension "GLX" missing on display ":0.0".
glmatrix: display ":0.0" does not support the GLX extension.

Yada yada yada. ...
Comment 2 Dan Reish 2004-07-03 23:36:00 EDT
w00t!

Following the instructions on nvidia.org fixed it.

In a nutshell, all I had to do was change my XF86Config file as follows:

5c4
<       Identifier     "Default Layout"
---
>       Identifier     "single head configuration"
31a31
> #     Load  "dri"
100c100
<       Driver      "nv"
---
>       Driver      "nvidia"

It now works beautifully.  Now the only problem I have with FC2 is the
fact that it blew away all my Gnome desktop settings. ...  :-/

Comment 3 Mike A. Harris 2004-07-04 04:02:19 EDT
This is not a Fedora Core 2 bug or X.Org X11 bug.

Nvidia's drivers install from tarball and the files that they install
are not managed at all by rpm.  RPM has no knowledge of the nvidia
driver being installed whatsoever.  When you upgrade your system,
a new kernel is installed that comes with the OS.  You must relink
the Nvidia proprietary video driver's kernel module to the new kernel
in order for it to work.  It is possible that you may also need to
upgrade to a newer nvidia driver which supports the new kernel.  It
may take some time for such updated driver to become available from
nvidia, in which case you may not be able to use their driver at all
until they release one for the new OS release.

Another problem, is that nvidia's driver overwrites several Red Hat
supplied files.  libglx is one of them, and when you upgrade your
OS, you get the libglx that is supplied with the OS, which overwrites
the one nvidia provides - because nvidia doesn't use rpm for package
installation, and so rpm has no idea that nvidia has replaced
libglx.

The solution to all of these problems, is to go to nvidia's website,
and make sure they have released a driver that is officially supported
by them for the OS release you are using - in this case Fedora Core
2.  Once you've confirmed they support Fedora Core 2, download the
driver for FC2 and follow Nvidia's instructions to install it and
get it working.

If you have further problems with the proprietary driver, please
contact Nvidia tech support for assistance, as Red Hat does not
provide support for 3rd party video drivers.

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.