Bug 1272014 - SELinux is preventing /usr/libexec/geoclue from 'getattr' accesses on the file /etc/resolv.conf.
SELinux is preventing /usr/libexec/geoclue from 'getattr' accesses on the fil...
Status: CLOSED DUPLICATE of bug 1271924
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:4d20b1da09dfb246efbdb599644...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 05:44 EDT by Gil Forcada
Modified: 2015-10-16 10:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 10:51:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gil Forcada 2015-10-15 05:44:40 EDT
Description of problem:
SELinux is preventing /usr/libexec/geoclue from 'getattr' accesses on the file /etc/resolv.conf.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that geoclue should be allowed getattr access on the resolv.conf file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep geoclue /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:geoclue_t:s0
Target Context                unconfined_u:object_r:home_bin_t:s0
Target Objects                /etc/resolv.conf [ file ]
Source                        geoclue
Source Path                   /usr/libexec/geoclue
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           geoclue2-2.2.0-1.fc22.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-128.13.fc22.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.1.7-200.fc22.x86_64 #1 SMP Mon
                              Sep 14 20:19:24 UTC 2015 x86_64 x86_64
Alert Count                   4
First Seen                    2015-10-15 10:02:24 EEST
Last Seen                     2015-10-15 12:00:06 EEST
Local ID                      0d68db0d-861b-4b52-8c00-c439e20099d2

Raw Audit Messages
type=AVC msg=audit(1444899606.526:1486): avc:  denied  { getattr } for  pid=2316 comm="geoclue" path="/etc/resolv.conf" dev="sdb1" ino=1048833 scontext=system_u:system_r:geoclue_t:s0 tcontext=unconfined_u:object_r:home_bin_t:s0 tclass=file permissive=0


type=SYSCALL msg=audit(1444899606.526:1486): arch=x86_64 syscall=stat success=no exit=EACCES a0=36bef0f18e a1=7ffce8a96b80 a2=7ffce8a96b80 a3=0 items=0 ppid=1 pid=2316 auid=4294967295 uid=990 gid=987 euid=990 suid=990 fsuid=990 egid=987 sgid=987 fsgid=987 tty=(none) ses=4294967295 comm=geoclue exe=/usr/libexec/geoclue subj=system_u:system_r:geoclue_t:s0 key=(null)

Hash: geoclue,geoclue_t,home_bin_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-128.13.fc22.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.1.7-200.fc22.x86_64
type:           libreport
Comment 1 Daniel Walsh 2015-10-16 10:51:25 EDT

*** This bug has been marked as a duplicate of bug 1271924 ***

Note You need to log in before you can comment on or make changes to this bug.