Bug 1272026 - Use obtain_device_list_from_udev=1 vdsm private lvm configuration
Use obtain_device_list_from_udev=1 vdsm private lvm configuration
Status: CLOSED DUPLICATE of bug 1272027
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.9
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Fred Rolland
Aharon Canan
storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 06:03 EDT by Nir Soffer
Modified: 2016-02-10 14:21 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-22 15:13:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Nir Soffer 2015-10-15 06:03:52 EDT
Description of problem:

Vdsm overrides lvm configuration for vdsm lvm calls. We are using 
obtain_device_list_from_udev=0 which was a workaround for old udev
bugs in EL 6.

The udev issues should be fixed in Fedora 21 and EL 7.

Test vdsm without obtain_device_list_from_udev=0 and remove this
option if it works now.

The advantage should be faster operation as lvm does not have to search
/dev for block devices but get the devices from udev.

See https://bugzilla.redhat.com/show_bug.cgi?id=1259587#c11
Comment 1 Yaniv Kaul 2015-10-20 05:54:53 EDT
What's the priority of this bug? Do we want it for 3.6.0?
Comment 2 Nir Soffer 2015-10-22 15:05:20 EDT
(In reply to Yaniv Kaul from comment #1)
> What's the priority of this bug? Do we want it for 3.6.0?

This is cleanup, using the platform as it was meant to be used, avoiding
problematic .cache files (that were broken recently in 7.2).

We want it in 3.6, but it is not urgent. Since the trivial patch is
ready and tested, I don't see a reason to wait.

ydary: this should be in next 3.6 release.
Comment 3 Nir Soffer 2015-10-22 15:13:42 EDT
Strange, we have this bug twice - this is a duplicate of bug 1272027.

I cannot explain how we have the same bug twice - maybe bugzilla failed
but created the bug, and I submitted again?

*** This bug has been marked as a duplicate of bug 1272027 ***

Note You need to log in before you can comment on or make changes to this bug.