Bug 127211 - gcc fails with internal error when compiling ffmpeg from CVS
gcc fails with internal error when compiling ffmpeg from CVS
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
http://www.gornall.net/bugs/gcc/info....
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-04 06:45 EDT by Simon Gornall
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-05 16:42:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed test case (45.13 KB, application/x-tar)
2004-10-05 16:38 EDT, Richard Henderson
no flags Details

  None (edit)
Description Simon Gornall 2004-07-04 06:45:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
All the detailed information is at the URL
http://www.gornall.net/bugs/gcc/info.html, but in summary:

check out ffmpeg from CVS
configure using './configure --prefix=/opt/ffmpeg'
make
gcc fails with an internal compiler error and recommends a bug report :-)



Version-Release number of selected component (if applicable):
gcc version 3.3.3 20040412 (Red Hat Linux 3.3.3-7)

How reproducible:
Always

Steps to Reproduce:
1. Check out ffmpeg from :pserver:anonymous@mplayerhq.hu:/cvsroot/ffmpeg
2. Run './configure'
3. Run 'make'

    

Actual Results:  gcc failed, as shown in the URL text

Expected Results:  ffmpeg ought to have compiled.

Additional info:
Comment 1 Richard Henderson 2004-10-04 19:19:11 EDT
Works for me.  Since it's unlikely that nothing happened in the cvs
repository in three months this isn't unsurprising.  Which is why
you should always follow the directions the compiler gave you, namely,

Preprocessed source stored into /tmp/ccMWqCsh.out file, please attach 
this to your bugreport.
Comment 2 Simon Gornall 2004-10-05 04:55:45 EDT
Agreed it's unlikely to be the same :-)

If you click on the URL above (www,gornall.net/....) and scroll to the bottom, the relevent 
source file is there.

Simon
Comment 3 Simon Gornall 2004-10-05 04:57:06 EDT
Re-opening in case the source code helps, and in case closed bugs are not delivered - 
what you expect me to know how this thing works ?? [grin]
Comment 4 Richard Henderson 2004-10-05 16:38:15 EDT
Created attachment 104803 [details]
preprocessed test case
Comment 5 Richard Henderson 2004-10-05 16:42:56 EDT
Even your preprocessed source works for me with 3.3.3-7.

Note You need to log in before you can comment on or make changes to this bug.