Bug 127214 - KDE keyboard indicator cannot be added to pannel by usual way on Fedora 2 Final
KDE keyboard indicator cannot be added to pannel by usual way on Fedora 2 Final
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kbd (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-04 08:46 EDT by Goran Blagojevic
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-08 16:52:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Goran Blagojevic 2004-07-04 08:47:00 EDT
Description of problem:
The usual way to add keyboard indicator to KDE panel is choosing
Regional & Accebility then Keyboard Layout from KDE Control Panel.
That is the same as execute:
kcmshell keyboard_layout
Keyboard layout(s) cannot be added because they cannot be read.

Version-Release number of selected component (if applicable):
Qt: 3.3.2
KDE: 3.2.2-4 Red Hat
KDE Control Module: 3.2.2-3 Red Hat

How reproducible:
It is always reproducible when you use KDE on Fedora 2 Final

Steps to Reproduce:
1. Login using KDE environment
2. Choose Preferences menu item, then choose Control Panel menu item,
then choose Regional & Accebility menu item, then choose Keyboard
Layout manu item, or ecexute:
kcmshell keyboard_layout
  
Actual results:
Any keyboard layout is not read and keyboard layout(s) cannot be added.

Expected results:
It is expected to be able to add keyboard layout(s) from the list and
get keyboard indicator on panel as result.

Additional info:
I have written by hand into:
<my_home_folder>/.kde/share/config/kxkbrc
something like:
[Layout]
Additional=sr,si,en_US
AdditionalEncodings=ISO8859-5,,ISO8859-1
Encoding=ISO8859-1
Layout=us
Model=pc104
Options=
ResetOldOptions=false
SwitchMode=Global
Use=true
Variants=si(basic),sr(basic),en_US(basic)
and executed:
kxkb
and I have now keyboard indicator. That is not usual way at all, I think.
Comment 1 Eido Inoue 2004-11-08 16:52:12 EST
works for me (i get the keyboard indicator below the RHN update
notification icon). I did have to check both the "Enable keyboard
layouts" (in Layout tab) to get it to work.

Note You need to log in before you can comment on or make changes to this bug.