Bug 127215 - Man cannot reproduce ' character in correct way on Fedora 2 Final
Man cannot reproduce ' character in correct way on Fedora 2 Final
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: man (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-04 09:15 EDT by Goran Blagojevic
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-22 12:49:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the output for the "man man" command. (16.64 KB, image/png)
2004-10-08 05:14 EDT, Francis Li
no flags Details
"man man" command output for LANG=zh_TW.UTF-8 (11.50 KB, image/png)
2004-10-08 06:00 EDT, Francis Li
no flags Details

  None (edit)
Description Goran Blagojevic 2004-07-04 09:15:46 EDT
Description of problem:
Character ' is always reproduced as â.

Version-Release number of selected component (if applicable):
man, version 1.5m

How reproducible:
It is always reproducible if man page contains character '

Steps to Reproduce:
1. Execute: man xpdf
2. Search for â alias '
  
Actual results:
Character ' is reproduced as â

Expected results:
Character ' must be reproduces as '

Additional info:
I have added into:
<my_home_folder>/.bash_profile
lines:
LANG=$LANG:sr.UTF-8
LANG=$LANG:si.UTF-8
export LANG
in order to make it possible writing Serbian letters in Open Office. I
am not sure wether that has affected man in any way or not. Other
applications are not affected. Anyway, I must add lines if I want to
use Open Office, and man pages can be read even some characters are
wrong reproduced.
Comment 1 Barry K. Nathan 2004-07-14 05:25:47 EDT
I'm not seeing ' get turned into â, but I am seeing ' get corrupted in
other ways with your LANG changes. Without them (i.e.
LANG=en_US.UTF-8) I do not have the problem.

BTW, what kind of terminal or terminal emulator are you using?
Comment 2 Francis Li 2004-10-08 05:14:01 EDT
Created attachment 104925 [details]
the output for the "man man" command.
Comment 3 Francis Li 2004-10-08 06:00:41 EDT
Created attachment 104929 [details]
"man man"  command output for LANG=zh_TW.UTF-8

Why should the ' character be converted ?
I suppose it should keep the same one-character in the utf-8.
Comment 4 Francis Li 2004-10-08 06:04:45 EDT
The Comment #2 was LANG=zh_TW.Big5
and I used gnome-terminal-2.6.0-2
Comment 5 Goran Blagojevic 2004-10-08 16:13:55 EDT
The problem is related to konsole, that is to KDE terminal emulator.
If gnome-terminal is being used, no problem exists. It is important
that gnome-terminal is adjust to Unicode encoding.
Comment 6 Eido Inoue 2004-10-22 12:49:06 EDT
When both current konsole and gnome-terminal are in proper UTF-8 mode,
as well as the locale, the quote renders correctly.

Note You need to log in before you can comment on or make changes to this bug.