Bug 1272150 - F23 TC9 installation hangs with "inst.ks=file:/..."
F23 TC9 installation hangs with "inst.ks=file:/..."
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 11:01 EDT by Nils Philippsen
Modified: 2015-10-15 11:42 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 11:30:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kickstart file with which I wanted to test rolekit deferred deployment (915 bytes, text/plain)
2015-10-15 11:01 EDT, Nils Philippsen
no flags Details
Console output with these additional kernel cmdline parameters: "rd.debug console=tty0 console=ttyS0 serial" (6.42 MB, text/plain)
2015-10-15 11:04 EDT, Nils Philippsen
no flags Details

  None (edit)
Description Nils Philippsen 2015-10-15 11:01:05 EDT
Created attachment 1083300 [details]
Kickstart file with which I wanted to test rolekit deferred deployment

Description of problem:
Using virt-install to test something else (rolekit deferred deployment from KS %post, see bug #1091300), I attempted to inject and use a local kickstart configuration file into the initrd of TC9 (Server spin). It never got as far as the graphical part of anaconda and eventually dropped me into a dracut emergency shell.

Version-Release number of selected component (if applicable):
anaconda-23.19.6-1.fc23

How reproducible:
Reproducible

Steps to Reproduce:

1. Download the attached Kickstart file rk.ks
2. One line (as root), add any debugging parameters to --extra-args as needed:

virt-install --name f23-rolekit-test --memory=2048 --cpu host --location https://dl.fedoraproject.org/pub/alt/stage/23_TC9/Server/x86_64/os/ --os-variant fedora22 --disk /var/lib/libvirt/images/f23-rolekit-test.qcow2,size=10,format=qcow2 --network network=default --initrd-inject rk.ks --extra-args 'inst.ks=file:/rk.ks'

Actual results:
Drops into dracut emergency shell after some time.

Expected results:
Continues to proper anaconda, installs packages/groups and executes the KS %post section, shuts down.

Additional info:
Comment 1 Nils Philippsen 2015-10-15 11:04 EDT
Created attachment 1083302 [details]
Console output with these additional kernel cmdline parameters: "rd.debug console=tty0 console=ttyS0 serial"

In the emergency shell, nothing is mounted at /sysroot and it seems to me as if it takes most of the time to wait for something to be mounted there.
Comment 2 Nils Philippsen 2015-10-15 11:09:53 EDT
Totally forgot to mention: This works flawlessly with the Beta tree (presumably anaconda-23.19.4-1.fc23).
Comment 3 Fedora Blocker Bugs Application 2015-10-15 11:13:54 EDT
Proposed as a Blocker for 23-final by Fedora user nphilipp using the blocker tracking app because:

 Makes https://fedoraproject.org/wiki/QA:Testcase_Kickstart_File_Path_Ks_Cfg which is a Beta release criterion.
Comment 4 Nils Philippsen 2015-10-15 11:14:42 EDT
Uhm, "Makes ... fail ..." of course.
Comment 5 Brian Lane 2015-10-15 11:30:16 EDT
Not a blocker. eth0 gets renamed to ens3 so the nic it is waiting for never appears.

Note You need to log in before you can comment on or make changes to this bug.