Bug 1272165 - [abrt] WARNING: CPU: 0 PID: 531 at drivers/iommu/intel-iommu.c:3796 quirk_ioat_snb_local_iommu+0xba/0xd0()
[abrt] WARNING: CPU: 0 PID: 531 at drivers/iommu/intel-iommu.c:3796 quirk_ioa...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:39a29ce2fae277e05bdc76badfb...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 11:38 EDT by Vadim Rutkovsky
Modified: 2016-09-26 03:39 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-26 03:39:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadim Rutkovsky 2015-10-15 11:38:05 EDT
Description of problem:


Additional info:
reporter:       libreport-2.6.2
WARNING: CPU: 0 PID: 531 at drivers/iommu/intel-iommu.c:3796 quirk_ioat_snb_local_iommu+0xba/0xd0()
BIOS assigned incorrect VT-d unit for Intel(R) QuickData Technology device
Modules linked in: shpchp(+) lpc_ich(+) acpi_cpufreq(-) edac_core ioatdma(+) i2c_i801 coretemp kvm_intel kvm i5k_amb dca nfsd auth_rpcgss nfs_acl lockd grace sunrpc amdkfd amd_iommu_v2 radeon i2c_algo_bit drm_kms_helper mptsas ttm scsi_transport_sas ata_generic mptscsih drm serio_raw pata_acpi mptbase
CPU: 0 PID: 531 Comm: systemd-udevd Not tainted 4.2.3-300.fc23.x86_64 #1
Hardware name: SGI.COM AltixXE250/X7DWN, BIOS 1.1b 10/01/2008
 0000000000000000 000000001fb0a917 ffff88007b3ff888 ffffffff81771fca
 0000000000000000 ffff88007b3ff8e0 ffff88007b3ff8c8 ffffffff8109e4a6
 0000000900000030 ffff88007cbd4000 0000000000000000 ffff88007cbd4000
Call Trace:
 [<ffffffff81771fca>] dump_stack+0x45/0x57
 [<ffffffff8109e4a6>] warn_slowpath_common+0x86/0xc0
 [<ffffffff814bf9a0>] ? alloc_domain+0xa0/0xa0
 [<ffffffff8109e59e>] warn_slowpath_fmt_taint+0x4e/0x70
 [<ffffffff814bfa5a>] quirk_ioat_snb_local_iommu+0xba/0xd0
 [<ffffffff813f1919>] pci_do_fixups+0xb9/0x190
 [<ffffffff813f1a20>] pci_fixup_device+0x30/0xb0
 [<ffffffff813e3ae7>] do_pci_enable_device+0x97/0x110
 [<ffffffff813e4b64>] pci_enable_device_flags+0xe4/0x130
 [<ffffffff813e4c66>] pcim_enable_device+0x56/0xc0
 [<ffffffffa0405088>] ioat_pci_probe+0x18/0x1a0 [ioatdma]
 [<ffffffff813e6055>] local_pci_probe+0x45/0xa0
 [<ffffffff8129a57d>] ? sysfs_do_create_link_sd.isra.2+0x6d/0xb0
 [<ffffffff813e724d>] pci_device_probe+0xed/0x140
 [<ffffffff814d0624>] driver_probe_device+0x1f4/0x450
 [<ffffffff814d0910>] __driver_attach+0x90/0xa0
 [<ffffffff814d0880>] ? driver_probe_device+0x450/0x450
 [<ffffffff814ce0ec>] bus_for_each_dev+0x6c/0xc0
 [<ffffffff814cfe2e>] driver_attach+0x1e/0x20
 [<ffffffff814cf97b>] bus_add_driver+0x1eb/0x280
 [<ffffffffa0087000>] ? 0xffffffffa0087000
 [<ffffffff814d1180>] driver_register+0x60/0xe0
 [<ffffffff813e593c>] __pci_register_driver+0x4c/0x50
 [<ffffffffa008708d>] ioat_init_module+0x8d/0x1000 [ioatdma]
 [<ffffffff81002123>] do_one_initcall+0xb3/0x200
 [<ffffffff81774b02>] ? preempt_schedule_common+0x22/0x40
 [<ffffffff81774b3c>] ? _cond_resched+0x1c/0x30
 [<ffffffff811ffc0e>] ? kmem_cache_alloc_trace+0x19e/0x220
 [<ffffffff817711fc>] ? do_init_module+0x28/0x1e7
 [<ffffffff81771234>] do_init_module+0x60/0x1e7
 [<ffffffff811230bf>] load_module+0x20ef/0x2730
 [<ffffffff8111f460>] ? __symbol_put+0x60/0x60
 [<ffffffff81123854>] SyS_init_module+0x154/0x1a0
 [<ffffffff81023885>] ? syscall_trace_leave+0xb5/0x110
 [<ffffffff817789ae>] entry_SYSCALL_64_fastpath+0x12/0x71
Comment 2 Laura Abbott 2016-09-23 15:26:11 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.

Note You need to log in before you can comment on or make changes to this bug.