Bug 1272219 - postgresql-devel: remove dependency on 'postgresql'
postgresql-devel: remove dependency on 'postgresql'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: postgresql (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pavel Raiskup
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 15:29 EDT by Pavel Raiskup
Modified: 2015-10-16 10:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 10:06:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Raiskup 2015-10-15 15:29:49 EDT
One issue I found while I was trying to resolve bug 1190346 is that
'postgresql-devel' requires 'postgresql' package (which happens to be multilib
unclean at this moment).

I haven't found the reason for this requirement, one might be that that
'/usr/bin/pg_config' is packaged in 'postgresql'.  But because '*-devel' always
requires '*-libs', we could probably put 'pg_config' into 'postgresql-libs'.
Removing this binary from 'postgresql' would not hurt because 'postgresql'
requires 'postgresql-libs'.
Comment 1 Pavel Raiskup 2015-10-16 10:06:58 EDT
After discussion with Honza, we decided to move the 'pg_config' from
postgresql to postgresql-devel (not into postgresql-libs).  This is to minimize
postgreqsl-libs payload which is definitely desired.

http://pkgs.fedoraproject.org/cgit/postgresql.git/commit/?id=4034635788132a1590

Note You need to log in before you can comment on or make changes to this bug.