Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1272231 - [RFE][nova]: multiple back-ends for nova-compute
Summary: [RFE][nova]: multiple back-ends for nova-compute
Keywords:
Status: CLOSED DUPLICATE of bug 1272228
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 7.0 (Kilo)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 8.0 (Liberty)
Assignee: Eoghan Glynn
QA Contact: nlevinki
URL: https://blueprints.launchpad.net/nova...
Whiteboard: upstream_milestone_none upstream_defi...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-10-15 19:52 UTC by Stephen Gordon
Modified: 2019-09-09 17:08 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 19:53:49 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Stephen Gordon 2015-10-15 19:52:16 UTC
Cloned from launchpad blueprint https://blueprints.launchpad.net/nova/+spec/multi-back-ends-for-nova-compute.

Description:

#1. Efficient node usage: Nova-compute is designed to configure with only one type of nova compute driver like kvm, vmware, citrix,etc. Here Hypervisors like kvm, the nova-compute is installed on the hypervisor itself.
So the CPU, memory load will be high as hypervisor is running on the nova-compute. But for the vmware hypervisors, nova-compute is installed on the separate node and its called proxy nova-compute. So the load on the proxy-compute node will be comparatively lesser and it will be more efficient if nova-compute node is allowed to configure multiple compute proxy driver similar to the cinder-volume multi-backend architecture. https://wiki.openstack.org/wiki/Cinder-multi-backend

#2. scalability: By enabling the multiple back-ends, it also helps to improve the scale-ability of the given compute proxy driver such as vmware vc driver.

Implementation Note
===============
It can be implemented by leveraging  the cinder implementation where only one instance of cinder-volume is installed, but when the cinder-volume service is started, it spawns one cinder-volume process for every back-end configured in the cinder.conf. In the same approach,
nova.conf will be as follows:

[DEAFULT]
....

#back_ends will have comma separated set of compute drivers section
#Each compute driver could be same or different
back_ends = vcdriver1, vcdriver2, xen1

[vcdriver1]
...

[vcdriver2]
...

[xen1]
...

With these configuration in place, when nova-compute starts, it will spawn 3 nova-compute one for each of the configured driver.

Specification URL (additional information):

None

Comment 2 Stephen Gordon 2015-10-15 19:53:49 UTC

*** This bug has been marked as a duplicate of bug 1272228 ***


Note You need to log in before you can comment on or make changes to this bug.