Bug 1272251 - Provide an option to list full URL when listing all repositories through hammer, currently some text is truncated
Provide an option to list full URL when listing all repositories through hamm...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: katello-agent (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 17:18 EDT by John Matthews
Modified: 2016-09-26 14:15 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-26 14:15:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Matthews 2015-10-15 17:18:16 EDT
Description of problem:

I had hoped to list all repositories and their URL with hammer.
Issue was some of the repositories had their URL truncated.


Example I see:
https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/supplementar...

Instead of:
https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/supplementary/os 


Version-Release number of selected component (if applicable):
katello-2.2.0.16-1.el7sat.noarch
rubygem-hammer_cli-0.1.4.12-1.el7sat.noarch


Sample output:

$ hammer -v repository list --organization "Default Organization" --full-results=true 
[Foreman] Username: admin
[Foreman] Password for admin: 
---|----------------------------------------------------------------------------------|----------------------------------------------|--------------|---------------------------------------------------------------------------------
ID | NAME                                                                             | PRODUCT                                      | CONTENT TYPE | URL                                                                             
---|----------------------------------------------------------------------------------|----------------------------------------------|--------------|---------------------------------------------------------------------------------
7  | JBoss Enterprise Application Platform 6 RHEL 6 Server RPMs x86_64 6Server        | JBoss Enterprise Application Platform        | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/jbeap/6/os     
1  | Puppet                                                                           | Fusor                                        | puppet       |                                                                                 
9  | Red Hat CloudForms Management Engine 5.3 Files x86_64                            | Red Hat CloudForms                           | file         | https://cdn.redhat.com/content/dist/cf-me/server/5.3/x86_64/files               
3  | Red Hat Enterprise Linux 6 Server Kickstart x86_64 6.7                           | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6.7/x86_64/kickstart          
2  | Red Hat Enterprise Linux 6 Server RPMs x86_64 6Server                            | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os             
5  | Red Hat Enterprise Linux 6 Server - Supplementary RPMs x86_64 6Server            | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/supplementar...
12 | Red Hat Enterprise Linux 7 Server - Extras RPMs x86_64                           | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/extras/os      
11 | Red Hat Enterprise Linux 7 Server Kickstart x86_64 7.1                           | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7.1/x86_64/kickstart          
13 | Red Hat Enterprise Linux 7 Server - Optional RPMs x86_64 7Server                 | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/optional/os    
14 | Red Hat Enterprise Linux 7 Server - RH Common RPMs x86_64 7Server                | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/rh-common/os   
10 | Red Hat Enterprise Linux 7 Server RPMs x86_64 7Server                            | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/os             
16 | Red Hat Enterprise Linux OpenStack Platform 7.0 director for RHEL 7 RPMs x86_... | Red Hat OpenStack                            | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack-di...
17 | Red Hat Enterprise Linux OpenStack Platform 7.0 for RHEL 7 Files x86_64 7Server  | Red Hat OpenStack                            | file         | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack-di...
15 | Red Hat Enterprise Linux OpenStack Platform 7.0 for RHEL 7 RPMs x86_64 7Server   | Red Hat OpenStack                            | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/openstack/7....
8  | Red Hat Enterprise Virtualization Management Agents RPMs x86_64 6Server          | Red Hat Enterprise Virtualization            | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/rhev-mgmt-ag...
6  | Red Hat Enterprise Virtualization Manager 3.5 RPMs x86_64 6Server                | Red Hat Enterprise Virtualization            | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/rhevm/3.5/os   
4  | Red Hat Satellite Tools 6.1 for RHEL 6 Server RPMs x86_64                        | Red Hat Enterprise Linux Server              | yum          | https://cdn.redhat.com/content/dist/rhel/server/6/6Server/x86_64/sat-tools/6....
18 | Red Hat Software Collections RPMs for Red Hat Enterprise Linux 7 Server x86_6... | Red Hat Software Collections for RHEL Server | yum          | https://cdn.redhat.com/content/dist/rhel/server/7/7Server/x86_64/rhscl/1/os     
---|----------------------------------------------------------------------------------|----------------------------------------------|--------------|---------------------------------------------------------------------------------
Comment 1 Bryan Kearney 2016-07-26 15:10:52 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 2 Chris Duryee 2016-09-26 14:15:59 EDT
If you are using the hammer output for something to feed in elsewhere, you can add '--output csv' to the beginning of the command (for example, hammer --output csv repository list).

I am closing since this is an older bug, but feel free to re-open if this doesn't solve your issue.

Note You need to log in before you can comment on or make changes to this bug.