Bug 1272253 - EC2 Root partition does not get resized to the available space after updates are applied
EC2 Root partition does not get resized to the available space after updates ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ec2-images (Show other bugs)
6.7
All All
unspecified Severity high
: rc
: ---
Assigned To: Joey Boggs
Martin Kočí
:
Depends On:
Blocks: 1269194 1279571
  Show dependency treegraph
 
Reported: 2015-10-15 17:21 EDT by Josh Carter
Modified: 2017-08-15 14:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1279571 (view as bug list)
Environment:
Last Closed: 2017-08-15 14:21:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Josh Carter 2015-10-15 17:21:52 EDT
Description of problem:

I did two tests all with c3.large instance types, though that doesn't matter.

#1 Create an instance from ami-0ff3f13f and I was able to resize the root partition.  I then created an AMI from this instance and launched a new instance with this new AMI and was able to resize the root partition.  Just wanted to see if remaking a new AMI caused the issue, it didn't.

#2 I create an instance from ami-0ff3f13f and patched it (yum -y update), which is what we do as part of our hardening process. I then created an AMI from this instance and launched a new instance with this new AMI was NOT able to resize the root partition.

Because we must fully patch ami-0ff3f13f (and make other configuration changes) before turning it over to our internal customers, it's effectively broken.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Note You need to log in before you can comment on or make changes to this bug.