Bug 1272259 - logind self destructs in udev_device_read_db.constprop () on resuming from sleep - systemd-logind killed by SIGABRT
logind self destructs in udev_device_read_db.constprop () on resuming from sl...
Status: CLOSED DUPLICATE of bug 1237069
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 18:11 EDT by Hin-Tak Leung
Modified: 2015-10-16 16:45 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-16 07:21:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hin-Tak Leung 2015-10-15 18:11:01 EDT
Description of problem:

logind self destructs in udev_device_read_db.constprop () on resuming from sleep - systemd-logind killed by SIGABRT .

(gdb) bt
#0  0x00007f7f9cbfef90 in __read_nocancel () from /lib64/libc.so.6
#1  0x00007f7f9cb86478 in __GI__IO_file_underflow () from /lib64/libc.so.6
#2  0x00007f7f9cb874ae in __GI__IO_default_uflow () from /lib64/libc.so.6
#3  0x00007f7f9cb7b0ca in __GI__IO_getline_info () from /lib64/libc.so.6
#4  0x00007f7f9cb7a05d in fgets () from /lib64/libc.so.6
#5  0x000055b79ce8e1f0 in udev_device_read_db.constprop ()
#6  0x000055b79cea00bd in udev_device_get_properties_list_entry ()
#7  0x000055b79cea0313 in udev_device_get_property_value ()
#8  0x000055b79ce99138 in seat_set_active ()
#9  0x000055b79ce99e7a in seat_read_active_vt ()
#10 0x000055b79ce7a532 in manager_dispatch_console ()
#11 0x000055b79cec4c20 in source_dispatch.lto_priv ()
#12 0x000055b79cea1600 in sd_event_dispatch ()
#13 0x000055b79ce79b04 in main ()
(gdb) q

id c55cb727608fd6be0a14480cb08da00f970731bd
reason:         systemd-logind killed by SIGABRT
time:           Thu 15 Oct 2015 17:42:20 BST
cmdline:        /usr/lib/systemd/systemd-logind
package:        systemd-219-24.fc22
uid:            0 (root)
count:          1
Directory:      /var/spool/abrt/ccpp-2015-10-15-17:42:18-831

(for some unknown reason 'abrt-cli report' hasn't worked for many months now, just hang)

Version-Release number of selected component (if applicable):
systemd-219-24.fc22

How reproducible:
once, but it causes X to die, which is annoying.

Steps to Reproduce:
1. suspend, resume
2. system seems to resume, but screen lighted up, but showed nothing (X died, it turned out), but somehow it still seems to repond to ctrl-alt-f3, so I got a text terminal
3. look at 'abrt-cli list' , dmesg, to see what happened.

Actual results:
logind died and took X with it.

Expected results:
resume successful

Additional info:
Comment 1 Hin-Tak Leung 2015-10-16 07:18:07 EDT
I'll hang on to the coredump for a bit, in case somebody want to respond - as I said, 'abrt-cli report' hasn't been working for a while -just takes forever and seem to be busy not doing much - otherwise I would just let 'abort-cli report' does its thing.
Comment 2 Jan Synacek 2015-10-16 07:21:08 EDT
I use suspend and resume all the time and logind never crashes. Since this bug happened only once and is basically unreproducible, I'm going to close it now.
Comment 3 Hin-Tak Leung 2015-10-16 16:45:26 EDT
(In reply to Jan Synacek from comment #2)
> I use suspend and resume all the time and logind never crashes. Since this
> bug happened only once and is basically unreproducible, I'm going to close
> it now.

I think that's callous - anyway, according to 'abrt-cli report', it seems to be a duplicate of bug 1237069, so it has happened to another person too, and bug 1237069 has a better back trace with line numbers.

*** This bug has been marked as a duplicate of bug 1237069 ***

Note You need to log in before you can comment on or make changes to this bug.