Bug 1272263 - Unexpected error while viewing Database table indexes
Unexpected error while viewing Database table indexes
Status: CLOSED DUPLICATE of bug 1212736
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
unspecified Severity high
: GA
: 5.5.0
Assigned To: Dan Clarizio
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 18:39 EDT by Nandini Chandra
Modified: 2015-11-11 15:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 10:50:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nandini Chandra 2015-10-15 18:39:52 EDT
Description of problem:
-----------------------
This error is thrown while viewing database table indexes:

undefined method `x_get_tree_vmdb_table_kids' for # <OpsController:0x00000001f410e0> [ops/x_show]


Snippet from production.log:

[----] F, [2015-10-15T18:32:55.061488 #2923:12b5998] FATAL -- : Error caught: [NoMethodError] undefined method `x_get_tree_vmdb_table_kids' for #<OpsController:0x000000047b4bf8>
/var/www/miq/vmdb/app/controllers/application_controller/explorer.rb:283:in `x_get_tree_objects'
/var/www/miq/vmdb/app/controllers/application_controller/explorer.rb:361:in `x_get_child_nodes_dynatree'
/var/www/miq/vmdb/app/controllers/ops_controller/db.rb:247:in `tree_add_child_nodes'
/var/www/miq/vmdb/app/controllers/ops_controller.rb:461:in `open_parent_nodes'
/var/www/miq/vmdb/app/controllers/ops_controller.rb:473:in `replace_right_cell'
/var/www/miq/vmdb/app/controllers/ops_controller.rb:205:in `tree_select'
/var/www/miq/vmdb/app/controllers/ops_controller/db.rb:90:in `x_show'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal/implicit_render.rb:4:in `send_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/abstract_controller/base.rb:198:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal/rendering.rb:10:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/abstract_controller/callbacks.rb:20:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/callbacks.rb:117:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/callbacks.rb:555:in `block (2 levels) in compile'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/callbacks.rb:505:in `call'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/callbacks.rb:92:in `__run_callbacks__'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/callbacks.rb:778:in `_run_process_action_callbacks'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/callbacks.rb:81:in `run_callbacks'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/abstract_controller/callbacks.rb:19:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal/rescue.rb:29:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal/instrumentation.rb:32:in `block in process_action'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/notifications.rb:164:in `block in instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/notifications/instrumenter.rb:20:in `instrument'
/opt/rh/cfme-gemset/gems/activesupport-4.2.4/lib/active_support/notifications.rb:164:in `instrument'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal/instrumentation.rb:30:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal/params_wrapper.rb:250:in `process_action'
/opt/rh/cfme-gemset/gems/activerecord-4.2.4/lib/active_record/railties/controller_runtime.rb:18:in `process_action'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/abstract_controller/base.rb:137:in `process'
/opt/rh/cfme-gemset/gems/actionview-4.2.4/lib/action_view/rendering.rb:30:in `process'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal.rb:196:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal/rack_delegation.rb:13:in `dispatch'
/opt/rh/cfme-gemset/gems/actionpack-4.2.4/lib/action_controller/metal.rb:237:in `block in action'


Version-Release number of selected component (if applicable):
----------------------
5.5.0.6


How reproducible:
----------------
Always


Steps to Reproduce:
------------------
1.Navigate to Configure->Configuration
2.From the Database accordion,click any table.
3.On the right,click any of the listed indexes for the table


Actual results:
---------------
Error occurs.


Expected results:
-----------------
No errors


Additional info:
---------------
Comment 2 Harpreet Kataria 2015-10-23 10:50:45 EDT

*** This bug has been marked as a duplicate of bug 1212736 ***

Note You need to log in before you can comment on or make changes to this bug.