Bug 1272272 - Pulp User agent should be more informative than simply "Ruby"
Pulp User agent should be more informative than simply "Ruby"
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Pulp (Show other bugs)
6.1.0
All Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 20:03 EDT by Paul Wayper
Modified: 2015-11-20 12:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 12:00:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Wayper 2015-10-15 20:03:47 EDT
Description of problem:

Pulp requests list their user agent simply as "Ruby":

10.20.30.40 - - [05/Oct/2015:10:32:22 -0700] "POST /pulp/api/v2/content/units/distribution/search/ HTTP/1.1" 200 1605341 "-" "Ruby"

Whereas other programs give a more complete program and version number, e.g.:

10.20.30.40 - - [05/Oct/2015:10:32:21 -0700] "GET /pulp/repos/dts/Library/content/dist/rhel/workstation/6/6.6/x86_64/supplementary/os/repodata/repomd.xml HTTP/1.1" 200 1820 "-" "urlgrabber/3.9.1 yum/3.2.29"

Version-Release number of selected component (if applicable):

pulp-admin-client-2.6.0.15-1.el7sat.noarch
pulp-docker-plugins-0.2.5-1.el7sat.noarch
pulp-katello-0.5-1.el7sat.noarch
pulp-nodes-common-2.6.0.15-1.el7sat.noarch
pulp-nodes-parent-2.6.0.15-1.el7sat.noarch
pulp-puppet-plugins-2.6.0.15-1.el7sat.noarch
pulp-puppet-tools-2.6.0.15-1.el7sat.noarch
pulp-rpm-admin-extensions-2.6.0.15-1.el7sat.noarch
pulp-rpm-handlers-2.6.0.15-1.el7sat.noarch
pulp-rpm-plugins-2.6.0.15-1.el7sat.noarch
pulp-selinux-2.6.0.15-1.el7sat.noarch
pulp-server-2.6.0.15-1.el7sat.noarch
python-isodate-0.5.0-4.pulp.el7sat.noarch
python-kombu-3.0.24-10.pulp.el7sat.noarch
python-pulp-agent-lib-2.6.0.15-1.el7sat.noarch
python-pulp-bindings-2.6.0.15-1.el7sat.noarch
python-pulp-client-lib-2.6.0.15-1.el7sat.noarch
python-pulp-common-2.6.0.15-1.el7sat.noarch
python-pulp-docker-common-0.2.5-1.el7sat.noarch
python-pulp-puppet-common-2.6.0.15-1.el7sat.noarch
python-pulp-rpm-common-2.6.0.15-1.el7sat.noarch
rubygem-smart_proxy_pulp-1.0.1.2-1.el7sat.noarch

How reproducible:

Always

Steps to Reproduce:
1. Configure runcible isonoscope with abulatory infrangulator, to ISO spec 31337.
2. Look at queries from Pulp on a Satellite 6 server.
3. Observe the user agent.

Actual results:

User agent is "Ruby"

Expected results:

User agent reflects the request coming from pulp and version number thereof, e.g. "pulp/2.6.0.15-1"
Comment 1 Bryan Kearney 2015-11-20 12:00:34 EST
I am closing this out. The agent is visible since katello is communicating with the  pulp instance. If clsoing this is an issue, please feel free to re-open with the business/customer impact.

Note You need to log in before you can comment on or make changes to this bug.