Bug 1272309 - [Docs] [Use Case] How to Configure Auto Scaling
[Docs] [Use Case] How to Configure Auto Scaling
Status: CLOSED CURRENTRELEASE
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
medium Severity medium
: async
: 7.0 (Kilo)
Assigned To: Martin Lopes
Radek Bíba
: Documentation, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-15 23:25 EDT by Andrew Dahms
Modified: 2016-01-17 18:23 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-17 18:23:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Dahms 2015-10-15 23:25:25 EDT
Create a standalone mini-guide that covers, end to end, how to configure auto-scaling in a RHEL-OSP environment.
Comment 5 ktenzer 2015-10-30 09:53:24 EDT
Feedback regarding document

I think we should mention at very beginning CPU utilization not memory since that is example.

1.1.3 A Stack involves all resources required to operate an application. It can be as simple as a single VM and it's resources or many VMs, resource dependencies that comprise a multi-tier application.

1.2 I would explain that we are using existing resources such as networks, etc and that the names may of course differ.

1.2 Step 4 I would mention setting polling to 60 seconds is not recommended for production but just test environments. Higher polling can result in higher load on control plane.

Otherwise great work!

In addition to this I have written information about taking auto-scaling to next step and auto-scaling applications. In this use case we create a webserver and simple application with load balancer, than use auto-scaling to scale-up / down. Also shown is how the Heat hooks work so you can scale manually using REST API calls and provide Stack output to user. Might be worth a follow on document:

http://keithtenzer.com/2015/10/05/auto-scaling-applications-with-openstack-heat/

Let me know if you need anything else?

Regards,

Keith Tenzer, Solutions Architect
Red Hat Certified Architect Level I
Red Hat GmbH, Werner-von-Siemens-Ring 11, 85630 Grasbrunn
Mobile: +49 151 440 51401
E-mail: ktenzer@redhat.com
Comment 7 Martin Lopes 2015-11-08 23:36:19 EST
Yep, it makes sense to have a follow-up guide that describes the more advanced use case. Will discuss with Andrew Dahms, our DPM.
Comment 9 Andrew Dahms 2015-11-11 21:18:32 EST
Assigning Radek as the QA contact.

Radek - could you take a look at the changes for this bug?
Comment 12 Martin Lopes 2016-01-04 19:52:21 EST
Raised BZ#1295599 for the application auto scaling use case.
Comment 13 Andrew Dahms 2016-01-17 18:23:29 EST
This content is live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.