Bug 1272458 - Default value Globally Subscribable during creating channel
Default value Globally Subscribable during creating channel
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
570
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Jan Hutař
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 08:51 EDT by Pavel Studeník
Modified: 2015-11-23 04:02 EST (History)
4 users (show)

See Also:
Fixed In Version: spacewalk-java-2.3.8-118
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 04:02:37 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Studeník 2015-10-16 08:51:38 EDT
Description of problem:

After upgrade package spacewalk-java-2.3.8-112.el6sat.noarch to spacewalk-java-2.3.8-112.el6sat.noarch then I get other default value for Globally Subscribable when I create channel by API

Version-Release number of selected component (if applicable):
spacewalk-java-2.3.8-112.el6sat.noarch

How reproducible:
always Satellite  5.7

Steps to Reproduce:
1. client.channel.software.create(key, CHANNEL, ...)
2. client.channel.software.isGloballySubscribable(key, CHANNEL)

Actual results:
>> ret = client.channel.software.isGloballySubscribable(key, CHANNEL)
>> print ret
0

Expected results:
>> ret = client.channel.software.isGloballySubscribable(key, CHANNEL)
>> print ret
1
Comment 1 Tomáš Kašpárek 2015-10-28 05:36:57 EDT
spacewalk.git(master): e6ffab4481d6f1c4b075df10283cb5df7d074e05
Comment 6 errata-xmlrpc 2015-11-23 04:02:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2503.html

Note You need to log in before you can comment on or make changes to this bug.