Bug 1272459 - Implement 'login_allowed' column in 'user show' command
Implement 'login_allowed' column in 'user show' command
Status: CLOSED DEFERRED
Product: ovirt-engine-extension-aaa-jdbc
Classification: oVirt
Component: Core (Show other bugs)
1.0.2
Unspecified Unspecified
unspecified Severity medium (vote)
: ---
: ---
Assigned To: Martin Perina
Pavel Stehlik
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 08:54 EDT by Ondra Machacek
Modified: 2017-06-16 11:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-06-16 11:59:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mperina: ovirt‑future?
omachace: planning_ack?
omachace: devel_ack?
omachace: testing_ack?


Attachments (Terms of Use)

  None (edit)
Description Ondra Machacek 2015-10-16 08:54:46 EDT
Description of problem:
This is continuation of bug 1267282.

Please consider of rewrite of 'login_allowed' column of users table.
It's very hard to read it as user. Or find a nice way to represent it to user.
Also please implement showing only by specific attributes which are missing:

$ ovirt-aaa-jdbc-tool user show admin --attribute=valid_to
Pattern for argument 'attribute' does not match, pattern is '(department|description|displayName|email|firstName|id|lastName|namespace|title)', value is 'valid_to'

It's:

nopasswd | disabled |      unlock_time       |   last_successful_login    
|  last_unsuccessful_login   | consecutive_failures |       valid_from       |        valid_to

Version-Release number of selected component (if applicable):
ovirt-engine-extension-aaa-jdbc-1.0.0-2.el6ev.noarch
Comment 1 Sandro Bonazzola 2016-05-02 06:04:30 EDT
Moving from 4.0 alpha to 4.0 beta since 4.0 alpha has been already released and bug is not ON_QA.
Comment 2 Yaniv Lavi (Dary) 2016-05-23 09:19:08 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 3 Yaniv Lavi (Dary) 2016-05-23 09:23:00 EDT
oVirt 4.0 beta has been released, moving to RC milestone.
Comment 4 Martin Perina 2016-05-25 11:43:28 EDT
Moving out of 4.0 release
Comment 5 Martin Perina 2017-06-16 11:59:18 EDT
I haven't seen anyone showing interest in this feature, but if needed, feel free to reopen.

Note You need to log in before you can comment on or make changes to this bug.