Bug 1272496 - AttributeError when client disconnects in an unclean way
AttributeError when client disconnects in an unclean way
Status: CLOSED CURRENTRELEASE
Product: vdsm
Classification: oVirt
Component: Core (Show other bugs)
4.17.9
Unspecified Unspecified
high Severity high (vote)
: ovirt-3.6.0-rc3
: 4.17.10
Assigned To: Piotr Kliczewski
Gonza
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 10:38 EDT by Nir Soffer
Modified: 2016-02-10 14:14 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 08:26:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
oourfali: ovirt‑3.6.0?
mgoldboi: exception?
pkliczew: planning_ack?
oourfali: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47406 master MERGED betterAsyncore: Fix AttributeError on disconnect Never
oVirt gerrit 47421 ovirt-3.6 MERGED betterAsyncore: Fix AttributeError on disconnect Never

  None (edit)
Description Nir Soffer 2015-10-16 10:38:23 EDT
Description of problem:

Recently we are handling SSLError is raised during recv; this happens
when client disconnect in an unclean way:
https://gerrit.ovirt.org/47358

The logging fix was merge to ovirt-3.6 branch on Oct 15:
https://gerrit.ovirt.org/47358

Unfortunately, we are logging the error incorrectly, which raises an
AtttibureError, hiding the original error and failing to close the 
connection as intended:

    Traceback (most recent call last):
      File "<stdin>", line 1, in <module>
    AttributeError: 'function' object has no attribute 'error' 

Version-Release number of selected component (if applicable):
ovirt-3.6 commit dadae9ed72ee447cae6dc8823584889e2622c1ba
Comment 1 Red Hat Bugzilla Rules Engine 2015-10-19 07:00:50 EDT
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 2 Yaniv Kaul 2015-10-21 04:10:06 EDT
Removed blocker request. This is not a blocker bug for oVirt 3.6.0 GA. If there's a new build, this can get in though.
Comment 3 Red Hat Bugzilla Rules Engine 2015-11-02 07:27:06 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 4 Sandro Bonazzola 2015-11-04 09:43:31 EST
This issue should be fixed in oVirt 3.6.0 released on November 4th 2015 but still need to be checked by QE
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-16 04:59:54 EST
Bug tickets that are moved to testing must have target release set to make sure tester knows what to test. Please set the correct target release before moving to ON_QA.
Comment 6 Yaniv Lavi 2015-11-16 08:32:29 EST
What is the status of this issue?
Comment 7 Gonza 2015-12-10 09:00:36 EST
Verified with:
ovirt-engine-3.6.2-0.0.master.20151209173828.git652be7e.el6.noarch

Successfully added and removed host.

From vdsm.log:
JsonRpc (StompReactor)::ERROR::2015-12-10 14:55:21,352::betterAsyncore::124::vds.dispatcher::(recv) SSL error during reading data: (104, 'Connection reset by peer')
Comment 8 Sandro Bonazzola 2015-12-22 08:26:46 EST
oVirt 3.6.0 has been released and the bz verified, moving to closed current release.

Note You need to log in before you can comment on or make changes to this bug.