Bug 1272549 - Exposing container images on a CV instead of repository level
Exposing container images on a CV instead of repository level
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Container Management (Show other bugs)
Unspecified
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Tom McKay
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 13:24 EDT by Dirk Herrmann
Modified: 2017-01-13 15:54 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-13 15:48:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dirk Herrmann 2015-10-16 13:24:53 EDT
Description of problem:

Currently Satellite6 exposes docker images using a custom naming convention ({org_label}-{LC_ENV}-{CV-name}-{product_name}-{upstream_repo_name AND image name}). A sample docker pull command for 2 OSE3 builder images looks like this:

docker pull sat6.example.com:5000/acme-web-dev-cv-con-webshop-container_images-openshift3_php-55-rhel7:latest
docker pull sat6.example.com:5000/acme-web-dev-cv-con-webshop-container_images-openshift3_postgresql-92-rhel7:latest

This naming convention used to expose images merges the upstream repo name (namespace) and image name beside some other Sat6 specific items (CV, Product, Org).

OpenShift Enterprise v3 by Red Hat expects that even if the namespace changes all images still are inside the same namespace (here: openshift3) as they are in our Red Hat registry:

# docker search openshift3
INDEX        NAME                                                              DESCRIPTION                                     STARS     OFFICIAL   AUTOMATED
[...]                   
redhat.com   registry.access.redhat.com/openshift3/php-55-rhel7                OpenShift Enterprise PHP 5.5 Builder Image      0                    
redhat.com   registry.access.redhat.com/openshift3/postgresql-92-rhel7         OpenShift Enterprise Postgresql 9.2             0      
[...]


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:

Currently container images are exposed on an individual Satellite 6 repository level. Since we need to create for each individual container a dedicated repository we always expose 1 image including all its versions / tags.

Expected results:

Container Images should be exposed on a content view level instead. This would allow to have a naming convention which is similar to the namespace in our RH registry. This requires that each CV/CCV which contains container images should be exposed as a separate registry which contains all repos and images belonging to the same namespace.



Additional info:
Comment 3 Bryan Kearney 2016-07-26 15:10:48 EDT
Moving 6.2 bugs out to sat-backlog.
Comment 4 Bryan Kearney 2017-01-13 15:48:01 EST
This is an older bug which I do not envision being addressed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.
Comment 5 Bryan Kearney 2017-01-13 15:54:44 EST
This is an older bug which I do not envision being addressed in the near term. I am closing this out. If you believe doing so is an issue, please feel free to re-open and provide additional business information. Thank you.

Note You need to log in before you can comment on or make changes to this bug.