Bug 127255 - variation in the no. of users reported by "w" and "top"
variation in the no. of users reported by "w" and "top"
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: procps (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karel Zak
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 06:57 EDT by arthin123
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-08 06:29:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description arthin123 2004-07-05 06:57:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
A customer is facing the following problem. 
He is using telnet to connect to the server and initially (after
system bootup) with the "top" command he sees 194 users and with "w"
he sees 194 users. But after 2 days, he sees a great variation in the
no. of users reported by both commands. The nos. vary from 20 to 200 -
eg. top shows 200 where as w shows only 20.This is on RHEL AS 3 & U2.

Here are the customers comments:
I noticed that whenever this problem occurs, after that
/var/run/utmpdoes not changed, even after logging and logout of the
users to the system.


Version-Release number of selected component (if applicable):
procps-2.0.13-9.2E

How reproducible:
Always

Steps to Reproduce:
1.Install RHEL 3 AS
2.Make multiple users login (telnet ) to the system (around 200 users).
3. Inconsistency in the no. of users reported by "w" and "top".
    

Actual Results:  Initially "top" and "w" says the no. of users are
194.But after 1-2 days it may showin w as 20 against in top as > 200.

Expected Results:  The no. of users reported by both "w" and "top"
should be same.

Additional info:
Comment 1 arthin123 2004-07-05 07:02:01 EDT
skgoel@omlogistics.co.in
Comment 2 KL Rajasekar 2004-07-09 02:39:21 EDT
klrajasekar@yahoo.com
Comment 3 Albert Cahalan 2004-07-20 13:40:20 EDT
Since "top" doesn't report users... huh???

Perhaps you have confused users with tasks.
Each user may have many tasks running, and
may leave tasks running when they log out.
Comment 4 Karel Zak 2005-09-08 06:29:11 EDT
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received the feedback we
requested, we will assume the problem was not reproduceable or has been fixed in
a later update for this product.

Users who have experienced this problem are encouraged to upgrade to the latest
update release, and if this issue is still reproduceable, please contact the Red
Hat Global Support Services page on our website for technical support options:
https://www.redhat.com/support

If you have a telephone based support contract, you may contact Red Hat at
1-888-GO-REDHAT for technical support for the problem you are experiencing.

Note You need to log in before you can comment on or make changes to this bug.