Bug 1272607 - DEPRECATION Warnings in evm.log
DEPRECATION Warnings in evm.log
Status: CLOSED CURRENTRELEASE
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.0
Assigned To: Libor Pichler
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-16 17:27 EDT by Thom Carlin
Modified: 2015-11-11 15:42 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-27 08:58:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-10-16 17:27:41 EDT
Description of problem:

Steady stream of the following messages:
* [DEPRECATION] using self/none may not be supported in the future. Instead use 'self'/'none' instead.
* [DEPRECATION] using inline/eval may not be supported in the future. Instead use 'unsafe-inline'/'unsafe-eval' instead.

Version-Release number of selected component (if applicable):

5.4.3.1.20151013111241_1c155a5

How reproducible:

100%

Steps to Reproduce:
1. Startup appliance
2. View evm.log
3.

Actual results:

DEPRECATION messages in evm.log

Expected results:

No messages

Additional info:

No specific reproducer yet.
Comment 2 Libor Pichler 2015-10-21 05:07:30 EDT
Hi Thom,

I was unable to reproduce this in latest code but I found that this issue
has been already solved by this https://github.com/ManageIQ/manageiq/pull/4647
(I was able to reproduce this in state of application immediately before this pull request)
Can you confirm, that we have not this issue in latest 5.5.0 also already, please ?

Thank you!
Comment 3 Thom Carlin 2015-10-27 08:58:52 EDT
Hi Libor,

Agreed, don't see in 5.5.0.7-beta1.3.20151021133253_ed40d96

Note You need to log in before you can comment on or make changes to this bug.