Bug 1272693 - [abrt] qemu-system-x86: hw_error(): qemu-system-x86_64 killed by SIGABRT
[abrt] qemu-system-x86: hw_error(): qemu-system-x86_64 killed by SIGABRT
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:fb9746a0da7ee3856c9fcd0079f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-17 13:51 EDT by İsmail Baydan
Modified: 2016-04-01 13:52 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-01 13:52:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (23.38 KB, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: cgroup (190 bytes, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: core_backtrace (1.81 KB, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: dso_list (15.20 KB, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: environ (2.05 KB, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: limits (1.29 KB, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: maps (70.78 KB, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: mountinfo (2.97 KB, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: namespaces (85 bytes, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: open_fds (965 bytes, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details
File: proc_pid_status (982 bytes, text/plain)
2015-10-17 13:51 EDT, İsmail Baydan
no flags Details

  None (edit)
Description İsmail Baydan 2015-10-17 13:51:16 EDT
Version-Release number of selected component:
qemu-system-x86-2.4.0.1-1.fc23

Additional info:
reporter:       libreport-2.6.3
backtrace_rating: 4
cmdline:        qemu-system-x86_64 ipfire.qcow2 -netdev tap,fd=27,id=hostnet0,vhost=on
crash_function: hw_error
executable:     /usr/bin/qemu-system-x86_64
global_pid:     9831
kernel:         4.2.3-300.fc23.x86_64
runlevel:       N 5
type:           CCpp
uid:            0

Truncated backtrace:
Thread no. 1 (3 frames)
 #2 hw_error at /usr/src/debug/qemu-2.4.0.1/cpus.c:589
 #3 isa_bus_irqs at hw/isa/isa-bus.c:67
 #4 pc_init1 at /usr/src/debug/qemu-2.4.0.1/hw/i386/pc_piix.c:214
Comment 1 İsmail Baydan 2015-10-17 13:51:25 EDT
Created attachment 1083968 [details]
File: backtrace
Comment 2 İsmail Baydan 2015-10-17 13:51:27 EDT
Created attachment 1083969 [details]
File: cgroup
Comment 3 İsmail Baydan 2015-10-17 13:51:30 EDT
Created attachment 1083970 [details]
File: core_backtrace
Comment 4 İsmail Baydan 2015-10-17 13:51:33 EDT
Created attachment 1083971 [details]
File: dso_list
Comment 5 İsmail Baydan 2015-10-17 13:51:36 EDT
Created attachment 1083972 [details]
File: environ
Comment 6 İsmail Baydan 2015-10-17 13:51:38 EDT
Created attachment 1083973 [details]
File: limits
Comment 7 İsmail Baydan 2015-10-17 13:51:41 EDT
Created attachment 1083974 [details]
File: maps
Comment 8 İsmail Baydan 2015-10-17 13:51:43 EDT
Created attachment 1083975 [details]
File: mountinfo
Comment 9 İsmail Baydan 2015-10-17 13:51:45 EDT
Created attachment 1083976 [details]
File: namespaces
Comment 10 İsmail Baydan 2015-10-17 13:51:48 EDT
Created attachment 1083977 [details]
File: open_fds
Comment 11 İsmail Baydan 2015-10-17 13:51:50 EDT
Created attachment 1083978 [details]
File: proc_pid_status
Comment 12 İsmail Baydan 2015-10-18 00:21:42 EDT
The user side is here

[ismail@lenovo ~]$ qemu-system-x86_64 

(process:2679): GLib-WARNING **: gmem.c:482: custom memory allocation vtable not supported
qemu: hardware error: Can't set isa irqs with no isa bus present.
CPU #0:
EAX=00000000 EBX=00000000 ECX=00000000 EDX=00000663
ESI=00000000 EDI=00000000 EBP=00000000 ESP=00000000
EIP=0000fff0 EFL=00000002 [-------] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0000 00000000 0000ffff 00009300
CS =f000 ffff0000 0000ffff 00009b00
SS =0000 00000000 0000ffff 00009300
DS =0000 00000000 0000ffff 00009300
FS =0000 00000000 0000ffff 00009300
GS =0000 00000000 0000ffff 00009300
LDT=0000 00000000 0000ffff 00008200
TR =0000 00000000 0000ffff 00008b00
GDT=     00000000 0000ffff
IDT=     00000000 0000ffff
CR0=60000010 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000000
FCW=037f FSW=0000 [ST=0] FTW=00 MXCSR=00001f80
FPR0=0000000000000000 0000 FPR1=0000000000000000 0000
FPR2=0000000000000000 0000 FPR3=0000000000000000 0000
FPR4=0000000000000000 0000 FPR5=0000000000000000 0000
FPR6=0000000000000000 0000 FPR7=0000000000000000 0000
XMM00=00000000000000000000000000000000 XMM01=00000000000000000000000000000000
XMM02=00000000000000000000000000000000 XMM03=00000000000000000000000000000000
XMM04=00000000000000000000000000000000 XMM05=00000000000000000000000000000000
XMM06=00000000000000000000000000000000 XMM07=00000000000000000000000000000000
Aborted (core dumped)
Comment 13 Cole Robinson 2015-10-19 17:28:36 EDT
The abrt report lists the command line as:

  qemu-system-x86_64 ipfire.qcow2 -netdev tap,fd=27,id=hostnet0,vhost=on

Which seems weird... is that the full command line you are using?
Is the disk image available anywhere, or did you install the VM yourself? If so, how?
Did this ever work with an older qemu version, or is this your first attempt?
Comment 14 İsmail Baydan 2015-10-20 08:24:19 EDT
(In reply to Cole Robinson from comment #13)
> The abrt report lists the command line as:
> 
>   qemu-system-x86_64 ipfire.qcow2 -netdev tap,fd=27,id=hostnet0,vhost=on
> 
> Which seems weird... is that the full command line you are using?
> Is the disk image available anywhere, or did you install the VM yourself? If
> so, how?
> Did this ever work with an older qemu version, or is this your first attempt?

Yes this is the full command line. I have installed it myself with the default iso. I did not try with older qemu version.
Comment 15 Cole Robinson 2015-10-20 11:00:17 EDT
Can you give me a link to the iso you used? What was the command line you used for installing?

The thing that confused me about that command line is where the fd value is coming from in -netdev tap,fd=27,id=hostnet0,vhost=on  . For me qemu just throws a bunch of warnings:

$ qemu-system-x86_64: -netdev tap,fd=27,id=hostnet0,vhost=on: TUNGETIFF ioctl() failed: Bad file descriptor
TUNSETOFFLOAD ioctl() failed: Bad file descriptor
Warning: netdev hostnet0 has no peer

So is there some other piece of your config?
Comment 16 İsmail Baydan 2015-10-20 11:17:07 EDT
(In reply to Cole Robinson from comment #15)
> Can you give me a link to the iso you used? What was the command line you
> used for installing?
> 
> The thing that confused me about that command line is where the fd value is
> coming from in -netdev tap,fd=27,id=hostnet0,vhost=on  . For me qemu just
> throws a bunch of warnings:
> 
> $ qemu-system-x86_64: -netdev tap,fd=27,id=hostnet0,vhost=on: TUNGETIFF
> ioctl() failed: Bad file descriptor
> TUNSETOFFLOAD ioctl() failed: Bad file descriptor
> Warning: netdev hostnet0 has no peer
> 
> So is there some other piece of your config?

It seams like a general problem when  I try with ubuntu 15.10 server cloud image I get same error. Look at example

[ismail@lenovo Downloads]$ qemu-system-x86_64 wily-server-cloudimg-amd64.img 

(process:16223): GLib-WARNING **: gmem.c:482: custom memory allocation vtable not supported
WARNING: Image format was not specified for 'wily-server-cloudimg-amd64.img' and probing guessed raw.
         Automatically detecting the format is dangerous for raw images, write operations on block 0 will be restricted.
         Specify the 'raw' format explicitly to remove the restrictions.
qemu: hardware error: Can't set isa irqs with no isa bus present.
CPU #0:
EAX=00000000 EBX=00000000 ECX=00000000 EDX=00000663
ESI=00000000 EDI=00000000 EBP=00000000 ESP=00000000
EIP=0000fff0 EFL=00000002 [-------] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0000 00000000 0000ffff 00009300
CS =f000 ffff0000 0000ffff 00009b00
SS =0000 00000000 0000ffff 00009300
DS =0000 00000000 0000ffff 00009300
FS =0000 00000000 0000ffff 00009300
GS =0000 00000000 0000ffff 00009300
LDT=0000 00000000 0000ffff 00008200
TR =0000 00000000 0000ffff 00008b00
GDT=     00000000 0000ffff
IDT=     00000000 0000ffff
CR0=60000010 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000000
FCW=037f FSW=0000 [ST=0] FTW=00 MXCSR=00001f80
FPR0=0000000000000000 0000 FPR1=0000000000000000 0000
FPR2=0000000000000000 0000 FPR3=0000000000000000 0000
FPR4=0000000000000000 0000 FPR5=0000000000000000 0000
FPR6=0000000000000000 0000 FPR7=0000000000000000 0000
XMM00=00000000000000000000000000000000 XMM01=00000000000000000000000000000000
XMM02=00000000000000000000000000000000 XMM03=00000000000000000000000000000000
XMM04=00000000000000000000000000000000 XMM05=00000000000000000000000000000000
XMM06=00000000000000000000000000000000 XMM07=00000000000000000000000000000000
Aborted (core dumped)
Comment 17 Cole Robinson 2015-10-20 13:52:06 EDT
Can you give me a URL link to the ubuntu image you used? I tried this:

https://cloud-images.ubuntu.com/wily/current/wily-server-cloudimg-amd64-disk1.img

And qemu at least started booting until it was looking for cloud-init config.
Comment 18 İsmail Baydan 2015-10-21 02:08:10 EDT
I have tried link you provided and the same result

[ismail@lenovo Downloads]$ qemu-system-x86_64 wily-server-cloudimg-amd64-disk1.img

(process:3052): GLib-WARNING **: gmem.c:482: custom memory allocation vtable not supported
qemu: hardware error: Can't set isa irqs with no isa bus present.
CPU #0:
EAX=00000000 EBX=00000000 ECX=00000000 EDX=00000663
ESI=00000000 EDI=00000000 EBP=00000000 ESP=00000000
EIP=0000fff0 EFL=00000002 [-------] CPL=0 II=0 A20=1 SMM=0 HLT=0
ES =0000 00000000 0000ffff 00009300
CS =f000 ffff0000 0000ffff 00009b00
SS =0000 00000000 0000ffff 00009300
DS =0000 00000000 0000ffff 00009300
FS =0000 00000000 0000ffff 00009300
GS =0000 00000000 0000ffff 00009300
LDT=0000 00000000 0000ffff 00008200
TR =0000 00000000 0000ffff 00008b00
GDT=     00000000 0000ffff
IDT=     00000000 0000ffff
CR0=60000010 CR2=00000000 CR3=00000000 CR4=00000000
DR0=0000000000000000 DR1=0000000000000000 DR2=0000000000000000 DR3=0000000000000000 
DR6=00000000ffff0ff0 DR7=0000000000000400
EFER=0000000000000000
FCW=037f FSW=0000 [ST=0] FTW=00 MXCSR=00001f80                                                                                                                                                                                                                                
FPR0=0000000000000000 0000 FPR1=0000000000000000 0000                                                                                                                                                                                                                         
FPR2=0000000000000000 0000 FPR3=0000000000000000 0000                                                                                                                                                                                                                         
FPR4=0000000000000000 0000 FPR5=0000000000000000 0000                                                                                                                                                                                                                         
FPR6=0000000000000000 0000 FPR7=0000000000000000 0000                                                                                                                                                                                                                         
XMM00=00000000000000000000000000000000 XMM01=00000000000000000000000000000000                                                                                                                                                                                                 
XMM02=00000000000000000000000000000000 XMM03=00000000000000000000000000000000                                                                                                                                                                                                 
XMM04=00000000000000000000000000000000 XMM05=00000000000000000000000000000000                                                                                                                                                                                                 
XMM06=00000000000000000000000000000000 XMM07=00000000000000000000000000000000                                                                                                                                                                                                 
Aborted (core dumped)
Comment 19 Cole Robinson 2015-10-21 09:55:20 EDT
(In reply to İsmail Baydan from comment #18)
> I have tried link you provided and the same result
> 
> [ismail@lenovo Downloads]$ qemu-system-x86_64
> wily-server-cloudimg-amd64-disk1.img
> 
> (process:3052): GLib-WARNING **: gmem.c:482: custom memory allocation vtable
> not supported
> qemu: hardware error: Can't set isa irqs with no isa bus present.
> CPU #0:

Can you provide the output of

qemu-system-x86_64 -version
which qemu-system-x86_64


When does qemu crash, immediately after starting?
Does plain 'qemu-system-x86_64' crash as well?
Comment 20 İsmail Baydan 2015-11-02 07:14:33 EST
[ismail@lenovo ~]$ qemu-system-x86_64 -version                                                                                                                                                                                                                                
                                                                                                                                                                                                                                                                              
(process:11316): GLib-WARNING **: gmem.c:482: custom memory allocation vtable not supported                                                                                                                                                                                   
QEMU emulator version 2.4.0.1 (qemu-2.4.0.1-1.fc23), Copyright (c) 2003-2008 Fabrice Bellard

Do not start immediately crashes.
Plain version crashes as well
Comment 21 Cole Robinson 2015-11-02 09:51:28 EST
What is the output of 'which qemu-system-x86_64'

Does 'yum reinstall qemu-system-x86' make any difference?
Comment 22 İsmail Baydan 2015-11-02 09:54:23 EST
[ismail@lenovo ~]$ which qemu-system-x86_64
/bin/qemu-system-x86_64

There is no difference after reinstall
Comment 23 Cole Robinson 2015-11-02 10:05:13 EST
Okay I'm very confused :) No idea what's going on

Does these two commands reproduce the crash?

qemu-system-x86_64 -M pc
qemu-system-x86_64 -M isapc
Comment 24 İsmail Baydan 2015-11-03 06:35:29 EST
Yes
Comment 25 Cole Robinson 2016-03-16 21:11:18 EDT
İsmail do you still see this with fully updated host?
Comment 26 İsmail Baydan 2016-03-28 07:10:25 EDT
No it seems the problem is solved. Thanks.

Note You need to log in before you can comment on or make changes to this bug.