Bug 1272741 - Failing to scale overcloud in RHEL-OSP 7.1
Failing to scale overcloud in RHEL-OSP 7.1
Status: CLOSED DUPLICATE of bug 1272740
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-18 07:32 EDT by Qasim Sarfraz
Modified: 2016-04-18 02:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-18 09:08:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Qasim Sarfraz 2015-10-18 07:32:53 EDT
Description of problem:
I am following the instructions in section 7.6 of official deployment guide. Following command is failing to to scale the overcloud:
$ openstack overcloud deploy --templates --compute-scale 2
After I execute this command controllers go into ERROR state.

Steps to Reproduce:
1- Create an overcloud with following command:
$  openstack overcloud deploy --templates --control-scale 3 --compute-scale 1 --control-flavor control --compute-flavor compute --ntp-server pool.ntp.org
2- Once the overcloud has been deployed use the following command to scale:
$ openstack overcloud deploy --templates --compute-scale 2

Actual results:
Failed deployment.

Expected results:
Overcloud should scale. In my case it should go from 1 compute nodes to 2 computes nodes.

Additional info:
If I use the following command to scale the overcloud it works:
openstack overcloud deploy --templates --control-scale 3 --compute-scale 2 --control-flavor control --compute-flavor compute --ntp-server pool.ntp.org

Is it a documentation bug? 
Also, I don't want to update the controller while scaling is there a way to do it?
Comment 2 Mike Burns 2015-10-18 09:08:25 EDT
Bug was opened twice. Closing this one

*** This bug has been marked as a duplicate of bug 1272740 ***

Note You need to log in before you can comment on or make changes to this bug.