Bug 1272751 - pdfmod coughs & dies on startup
pdfmod coughs & dies on startup
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: pdfmod (Show other bugs)
22
ia64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Ismael Olea
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-18 08:49 EDT by David Tonhofer
Modified: 2015-10-19 06:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 06:24:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Tonhofer 2015-10-18 08:49:08 EDT
Description of problem:
-----------------------

pdfmod coughs & dies on startup.

In this case, trying to read a PDF from manning.com. So far, other PDFs worked fine:


$ pdfmod Type-Driven_Developm_v2_MEAP.pdf 

[1 Debug 14:41:04.954] Starting PdfMod 0.9.1
[1 Debug 14:41:04.977] Initializing i18n catalog from /usr/share/locale/
[1 Debug 14:41:05.007] Loaded custom AccelMap from /home/hobbes/.config/pdfmod/gtk_accel_map
[1 Debug 14:41:05.019] Cache directory set to /home/hobbes/.cache/pdfmod

(PdfMod:20113): Gtk-WARNING **: Theme directory apps/system-power-actions of theme breeze has no size field


(PdfMod:20113): Gtk-WARNING **: Theme directory apps/toolbar of theme breeze has no size field


(PdfMod:20113): Gtk-WARNING **: Theme directory categories/kickoff-menu-tabs of theme breeze has no size field

[1 Debug 14:41:05.348] Loaded Type-Driven_Developm_v2_MEAP.pdf

(PdfMod:20113): GLib-CRITICAL **: Source ID 30 was not found when attempting to remove it
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.DllNotFoundException: libpoppler-glib.so.8
  at (wrapper managed-to-native) Poppler.Document:poppler_document_new_from_file (intptr,intptr,intptr&)
  at Poppler.Document.NewFromFile (System.String uri, System.String password) [0x00000] in <filename unknown>:0 
  at PdfMod.Pdf.Document.get_PopplerDoc () [0x00000] in <filename unknown>:0 
  at PdfMod.Pdf.Document.GetSurface (PdfMod.Pdf.Page page, Int32 w, Int32 h, Int32 min_width) [0x00000] in <filename unknown>:0 
  at PdfMod.Gui.PageCell.Render (Cairo.Context cr, Double width, Double height, CellRendererState state) [0x00000] in <filename unknown>:0 
  at PdfMod.Gui.CairoCell.Render (Gdk.Drawable window, Gtk.Widget widget, Rectangle background_area, Rectangle cell_area, Rectangle expose_area, CellRendererState state) [0x00000] in <filename unknown>:0 
  at Gtk.CellRenderer.Render_cb (IntPtr item, IntPtr window, IntPtr widget, Gdk.Rectangle& background_area, Gdk.Rectangle& cell_area, Gdk.Rectangle& expose_area, CellRendererState flags) [0x00000] in <filename unknown>:0 
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.CellRenderer.Render_cb(IntPtr item, IntPtr window, IntPtr widget, Rectangle ByRef background_area, Rectangle ByRef cell_area, Rectangle ByRef expose_area, CellRendererState flags)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at PdfMod.Gui.Client..ctor(Boolean loadFiles)
   at PdfMod.PdfMod.Main(System.String[] args)
Cairo.Context: called from finalization thread, programmer is missing a call to Dispose

(PdfMod:20113): GLib-CRITICAL **: Source ID 35 was not found when attempting to remove it


Version-Release
---------------

pdfmod 0.9.1-8.fc21

(Weirdly, it is labeled as FC21. How come?)


How reproducible:
----------------

Always
Comment 1 Ismael Olea 2015-10-19 06:24:21 EDT
Thanks for your interest but this kind of bugs should be reported directly to upstream: https://bugzilla.gnome.org/page.cgi?id=browse.html&product=pdfmod

I just manage the packaging problems, sorry.




> pdfmod 0.9.1-8.fc21
>
> (Weirdly, it is labeled as FC21. How come?)

Because there is no change of dependencies or binary restrictions so package is still up to date.

Note You need to log in before you can comment on or make changes to this bug.