Bug 127276 - Texinfo is too old for gcc mainline
Texinfo is too old for gcc mainline
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 15:18 EDT by H.J. Lu
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 4.7-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-20 12:36:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description H.J. Lu 2004-07-05 15:18:11 EDT
After this patch

http://gcc.gnu.org/ml/gcc-patches/2004-07/msg00335.html

I can no longer build gcc mainline on FC 2 with its texinfo. I got

if [ xinfo = xinfo ]; then \
        makeinfo --split-size=5000000 --no-split -I
/net/gnu/export/gnu/src/gcc/gcc/gcc/doc \
                -I /net/gnu/export/gnu/src/gcc/gcc/gcc/doc/include -o
doc/gccint.info /net/gnu/export/gnu/src/gcc/gcc/gcc/doc/gccint.texi; \
fi
/net/gnu/export/gnu/src/gcc/gcc/gcc/doc/sourcebuild.texi:215: Unknown 
command
`comma'.
/net/gnu/export/gnu/src/gcc/gcc/gcc/doc/sourcebuild.texi:215: 
Misplaced {.
/net/gnu/export/gnu/src/gcc/gcc/gcc/doc/sourcebuild.texi:215: 
Misplaced }.
/net/gnu/export/gnu/src/gcc/gcc/gcc/doc/sourcebuild.texi:215: Unknown 
command
`comma'.
/net/gnu/export/gnu/src/gcc/gcc/gcc/doc/sourcebuild.texi:215: 
Misplaced {.
/net/gnu/export/gnu/src/gcc/gcc/gcc/doc/sourcebuild.texi:215: 
Misplaced }.
makeinfo: Removing output file `doc/gccint.info' due to errors; use --
force to
preserve.
make[4]: *** [doc/gccint.info] Error 1
Comment 1 Tim Waugh 2004-07-05 18:01:17 EDT
You don't say what version of texinfo you're using, but from the
product version I'm guessing texinfo-4.6-3: please confirm.

Note You need to log in before you can comment on or make changes to this bug.