Bug 1272760 - Upgrade with dnf failed due to proprietary nvidia driver incompatibilty with new Xserver
Upgrade with dnf failed due to proprietary nvidia driver incompatibilty with ...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: dnf-plugin-system-upgrade (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-18 10:30 EDT by Richard Geary
Modified: 2015-10-19 14:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 14:25:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Geary 2015-10-18 10:30:14 EDT
Description of problem:
After upgrading from Fedora 21 to 23 with dnf, the system did not boot.  It would hang at the "Switching Root" stage of the boot process, and the screen would flicker to a black screen & back

Version-Release number of selected component (if applicable):
Fedora 23

How reproducible:
Every time

Steps to Reproduce:
1. Install Fedora 21 + proprietary nvidia drivers 352.30 with Geforce GTX 460
2. Upgrade to Fedora 23 without removing nvidia drivers
3.

Actual results:
Hang at boot

Expected results:
dnf upgrade to fail and tell me to change to nouveau
Even better, dnf system-upgrade could provide instructions on how to remove nvidia (which includes unblacklisting nouveau)

Additional info:

Saw this in journalctl :
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: Module class: X.Org Video Driver
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: ================ WARNING WARNING WARNING WARNING ================
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: This server has a video driver ABI version of 20.0 that is not
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: supported by this NVIDIA driver.  Please check
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: http://www.nvidia.com/ for driver updates or downgrade to an X
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: server with a supported driver ABI.
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: =================================================================
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: (EE) NVIDIA: Use the -ignoreABI option to override this check.
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: (II) UnloadModule: "nvidia"
Oct 17 22:41:54 desktop.home /usr/libexec/gdm-x-session[10855]: (II) Unloading nvidia
Comment 1 Will Woods 2015-10-19 14:25:08 EDT
All dnf system-upgrade does is install packages; it's up to the package owners to make sure the packages actually work. I don't own nvidia's driver packages, so I can't really fix problems they cause.

This is something you should probably talk to nvidia about.

Note You need to log in before you can comment on or make changes to this bug.