Bug 1272763 - [RFE] Please include support for RHEV/Ovirt Agents at install time.
[RFE] Please include support for RHEV/Ovirt Agents at install time.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Docs Install Guide (Show other bugs)
6.1.2
All Linux
low Severity low (vote)
: 6.2.9
: 6.2
Assigned To: Julie
Russell Dickenson
: FutureFeature, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-18 12:35 EDT by Zak Brown
Modified: 2017-03-28 16:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-03-28 16:47:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zak Brown 2015-10-18 12:35:54 EDT
Description of problem:

The documentation is very specific that at install time only three repositories should be enabled.  For good performance and manageability it's helpful to have the RHEV/oVirt guest agents installed.

In RHEL 7 those are located in this repo:
rhel-7-server-rh-common-rpms
Red Hat Enterprise Linux 7 Server - RH Common (RPMs)

In RHEL 6 they are located in this repo:
rhel-6-server-optional-rpms
Red Hat Enterprise Linux 6 Server - Optional (RPMs)

The package is rhevm-guest-agent-common

Additional info:

Please add support for having those repos enabled and that package installed and the associated services running at install-time.
Comment 4 Andrew Dahms 2017-03-16 01:10:29 EDT
Hi Brad,

It has been some time since this bug was raised, and I apologize that we are only getting to this now.

To help clarify the request in this bug, is this seeking advice on how to install the agents on hosts that Satellite Server manages, or on Satellite Server itself?

Let me know what you think.

Kind regards,

Andrew
Comment 5 Zak Brown 2017-03-16 11:53:19 EDT
Andrew,

The documentation is very specific about which repositories should be enabled on the system where Satellite is to be installed.

If the Satellite Server is being hosted on RHV we should provide information on enabling the RHV guest agents.  Since these are helpful for managing Satellite on top of RHV.

The essence of the problem here is that we (Red Hat) often don't think through the experience of using several of our solutions together.

This request initially came out of a customer PoC where they implemented Satellite 6, RHV, Red Hat Storage, CloudForms and JBoss EAP.  Over and over we found that some of the connection points we needed between those products weren't expressly supported or documented.

I think that a documentation note that says something like:

<snip>
If Satellite 6 running on RHEL 7 and is hosted on Red Hat Virtualization then enable this repo:
Red Hat Enterprise Linux 7 Server - RH Common (RPMs)
rhel-7-server-rh-common-rpms

and install this package:
rhevm-guest-agent-common
</snip>

Otherwise the documentation implies that having the RHV guest tools installed is unsupported.
-Zak
Comment 6 Andrew Dahms 2017-03-16 19:21:14 EDT
Hi Zak,

Thank you for the clarification, and understood!

Now assigning to Julie for review.

Julie - the RHV documentation contains a detailed section on installing the agents here:

https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.0/html-single/virtual_machine_management_guide/#Installing_the_Guest_Agents_and_Drivers_on_Red_Hat_Enterprise_Linux

I suspect a good approach may be to add a new section under the following section on additional configuration after installing Satellite Server to let people know that if their Satellite Server is hosted on RHV, it is recommended that they install the agents:

https://access.redhat.com/documentation/en-us/red_hat_satellite/6.2/html-single/installation_guide/#performing_additional_configuration_satellite

Perhaps a short sentence or two talking about when to install the agents (when hosted on RHV), what the agents do, and a link to the section in the RHV documentation on how to install them.

What do you think?
Comment 7 Zak Brown 2017-03-17 16:24:30 EDT
That sounds good.

Can we include an explicit statement that installing the agents is supported?
Comment 8 Julie 2017-03-23 01:49:10 EDT
(In reply to Zak Brown from comment #7)
hey Zak,
   Thanks for your feedback. I have added a note to 3.1.3. Configuring Repositories:
----
If you are installing Red Hat Satellite on Red Hat Virtualization (RHV), you also need to enable the Red Hat Common repository, and install RHV guest agents and drivers. See Installing the Guest Agents and Drivers on Red Hat Enterprise Linux (https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.0/html-single/virtual_machine_management_guide/#Installing_the_Guest_Agents_and_Drivers_on_Red_Hat_Enterprise_Linux) for more information. 
----

Documentation Link:
http://ccs-jenkins.gsslab.brq.redhat.com:8080/job/doc-Red_Hat_Satellite-6-Installation_Guide-branch-BZ-1272763/lastSuccessfulBuild/artifact/index.html#configuring_repositories_satellite

Please let me know if this is okay and if you have any feedback.

Kind regards,
Julie
Comment 13 Andrew Dahms 2017-03-28 16:47:34 EDT
This content is live on the Customer Portal.

Closing.

Note You need to log in before you can comment on or make changes to this bug.