Bug 127280 - rpm --addsign (or --resign) corrupts rpm files
rpm --addsign (or --resign) corrupts rpm files
Status: CLOSED DUPLICATE of bug 127113
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-05 17:21 EDT by ulisses
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ulisses 2004-07-05 17:21:46 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
I downloaded this rpm v3 binary file from freepascal.org
(ftp://ftp.freepascal.org/pub/fpc/dist/Linux/rpm/fpc-1.0.10-0.i386.rpm)
and when I try to add my gpg signature to it, the rpm file seems
corrupted after the process. When I do 'rpm -qip
fpc-1.0.10-0.i386.rpm', it always ends up with:
'error: fpc-1.0.10-0.i386.rpm: rpmReadSignature failed: region
trailer: BAD, tag 61 type 7 offset 48 count 16'. The rpm files I build
with 'rpmbuild --sign' are fine though.


Version-Release number of selected component (if applicable):
rpm-4.3.1-0.3

How reproducible:
Always

Steps to Reproduce:
1. rpm --addsign fpc-1.0.10-0.i386.rpm
2. rpm -qip fpc-1.0.10-0.i386.rpm
3.
    

Actual Results:  rpm ended up with the following error:
'error: fpc-1.0.10-0.i386.rpm: rpmReadSignature failed: region
trailer: BAD, tag 61 type 7 offset 48 count 16'


Expected Results:  The package information should have been listed.


Additional info:
Comment 1 Jeff Johnson 2004-07-06 08:09:06 EDT

*** This bug has been marked as a duplicate of 127113 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:04:20 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.