Bug 1272820 - Hostname is inconsistent between rhevh and rhevm after auto-install with management_server
Hostname is inconsistent between rhevh and rhevm after auto-install with mana...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.5
Unspecified Unspecified
medium Severity low
: ovirt-3.6.1
: ---
Assigned To: Douglas Schilling Landgraf
Huijuan Zhao
node
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-18 22:09 EDT by Huijuan Zhao
Modified: 2016-02-10 14:17 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-10 14:20:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot rhevh hostname (59.60 KB, image/png)
2015-10-18 22:09 EDT, Huijuan Zhao
no flags Details
screenshot rhevm name (134.01 KB, image/png)
2015-10-18 22:10 EDT, Huijuan Zhao
no flags Details
log hostname inconsistent (7.11 MB, application/x-gzip)
2015-10-18 22:12 EDT, Huijuan Zhao
no flags Details

  None (edit)
Description Huijuan Zhao 2015-10-18 22:09:38 EDT
Created attachment 1084237 [details]
screenshot rhevh hostname

Description of problem:
After auto-install with management_server, rhevh register to rhevm successful, but the "Hostname" on rhevh is inconsistent with "name" on rhevm (FYI, screenshot in attach)

Version-Release number of selected component (if applicable):
rhev-hypervisor-6-6.7-20151015.1.el6ev
ovirt-node-3.2.3-23.el6.noarch

How reproducible:
test 2 times on machine dell-per510-01.qe.lab.eng.nay.redhat.com, both can reproduce.

Steps to Reproduce:
1. Auto install rhev-hypervisor-6-6.7-20151015.1.el6ev with parameters as follows:
storage_init=/dev/sda BOOTIF=em1 management_server=10.66.72.99:443 adminpw=OKr05SbCu3D3g firstboot
2. Check the Hostname on rhevh TUI, check the Name on rhevm.
 
Actual results:
After step2, the Hostname on rhevh TUI is "dell-per510-01.qe.lab.eng.nay.redhat.com",
the Name on rhevm is "localhost.localdomain".

Expected results:
Hostname on rhevh TUI should be same with the Name on rhevm.


Additional info:
Comment 1 Huijuan Zhao 2015-10-18 22:10 EDT
Created attachment 1084238 [details]
screenshot rhevm name
Comment 2 Huijuan Zhao 2015-10-18 22:12 EDT
Created attachment 1084239 [details]
log hostname inconsistent
Comment 3 Fabian Deutsch 2015-10-19 04:56:25 EDT
To me this looks like it could be a dupe of bug 1241712
Comment 4 Douglas Schilling Landgraf 2015-10-22 10:44:24 EDT
The vdsm-reg log shows that your system registered to RHEVM as hostname: localhost.localdomain.

=== vdsm.reg log ===
MainThread::DEBUG::2015-10-16 07:48:09,497::vdsm-reg-setup::140::root::registerVDS URI= /RHEVManagerWeb/VdsAutoRegistration.aspx?vds_ip=10.66.110.242&__VIEWSTATE=&vds_unique_id=4C4C4544-0058-3810-8033-B2C04F363358_00%3A1b%3A21%3A36%3A79%3Af0&vds_name=localhost.localdomain&ticket=&port=54321
=== vdsm.reg log ===

Could you please share the output of command below?
# cat /proc/sys/kernel/hostname

During my tests with the iso rhev-hypervisor-6-6.7-20151015.1.el6ev the hostname didn't change from localhost.localdomain. It seems we are affect to bz#1241712
Comment 5 Huijuan Zhao 2015-10-23 04:42:41 EDT
Douglas, I tested 4 times on the same machine: dell-per510-01.qe.lab.eng.nay.redhat.com, and 2 times on another machine, but can not reproduce this issue now. When I reported bug, I encountered this issue one more times.

I think this issue is probabilistic/race condition issue,I will lower the severity to low, and reserve for a period of time to see whether it can reproduce.
Comment 7 Douglas Schilling Landgraf 2015-11-10 14:20:50 EST
(In reply to Huijuan Zhao from comment #5)
> Douglas, I tested 4 times on the same machine:
> dell-per510-01.qe.lab.eng.nay.redhat.com, and 2 times on another machine,
> but can not reproduce this issue now. When I reported bug, I encountered
> this issue one more times.
> 
> I think this issue is probabilistic/race condition issue,I will lower the
> severity to low, and reserve for a period of time to see whether it can
> reproduce.

Thanks Huijuan,

I am closing this bug for now, please re-open in case you see it again so we can research. The original bug in platform bz#1241712 was closed today by PM as well.

Note You need to log in before you can comment on or make changes to this bug.