Bug 1272898 - ipv6calc-0.99.1-13.fc24 FTBFS: ./test_mod_ipv6calc.sh: line 209: 18736 Segmentation fault (core dumped) /usr/sbin/httpd -X -e info -d $dir_base
ipv6calc-0.99.1-13.fc24 FTBFS: ./test_mod_ipv6calc.sh: line 209: 18736 Segmen...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: ipv6calc (Show other bugs)
24
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Peter Bieringer
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On: 1272234
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 03:44 EDT by Petr Pisar
Modified: 2017-01-05 02:05 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-05 02:05:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-10-19 03:44:47 EDT
ipv6calc-0.99.1-13.fc24 fails to build in F24 because tests fail:

NOTICE: base directory is     : /tmp/mod_ipv6calc.M5FJF
NOTICE: ipv6calc module config: /tmp/mod_ipv6calc.M5FJF/conf.d/ipv6calc.conf
NOTICE: error log             : /tmp/mod_ipv6calc.M5FJF/logs/error_log
NOTICE: access log            : /tmp/mod_ipv6calc.M5FJF/logs/access_log
NOTICE: anonymized access log : /tmp/mod_ipv6calc.M5FJF/logs/access_anon_log
NOTICE: run test requests
NOTICE: test: 10.5.125.97
INFO  : access log entry
10.5.125.97 - - [14/Oct/2015:20:34:15 +0000] "GET / HTTP/1.1" 200 161 "-" "curl/7.45.0"
INFO  : anonymized access log entry
10.5.125.0 "-/-/reserved(RFC1918#3)/anonymize" - [14/Oct/2015:20:34:15 +0000] "GET / HTTP/1.1" 200 161 "-" "curl/7.45.0"
INFO  : error log entry
[Wed Oct 14 20:34:15.872524 2015] [ipv6calc:debug] [pid 18736] mod_ipv6calc.c(589): [client 10.5.125.97:60310] client IP address: 10.5.125.97  family: 10
[Wed Oct 14 20:34:15.872576 2015] [ipv6calc:debug] [pid 18736] mod_ipv6calc.c(1010): [client 10.5.125.97:60310] client IP address registry: reserved(RFC1918#3)
[Wed Oct 14 20:34:15.872591 2015] [ipv6calc:debug] [pid 18736] mod_ipv6calc.c(1071): [client 10.5.125.97:60310] client IP address anonymized: 10.5.125.0
NOTICE: test: 10.5.127.157
./test_mod_ipv6calc.sh: line 209: 18736 Segmentation fault      (core dumped) /usr/sbin/httpd -X -e info -d $dir_base
ERROR : curl request to 10.5.127.157:8080 failed
Makefile:61: recipe for target 'test' failed
make[1]: Leaving directory '/builddir/build/BUILD/ipv6calc-0.99.1/mod_ipv6calc'

Difference between working and failing build root:

        httpd-devel 	2.4.16-1.fc24 	> 	2.4.17-2.fc24
	httpd 	2.4.16-1.fc24 	> 	2.4.17-2.fc24
	httpd-tools 	2.4.16-1.fc24 	> 	2.4.17-2.fc24
	httpd-filesystem 	2.4.16-1.fc24 	> 	2.4.17-2.fc24
	glib2 	2.46.0-1.fc24 	> 	2.46.1-1.fc24
	python3-dnf 	1.1.2-4.fc24 	> 	1.1.3-1.fc24
	hawkey 	0.6.1-2.fc24 	> 	0.6.2-1.fc24
	python3-dnf-plugins-core 	0.1.12-3.fc24 	> 	0.1.13-1.fc24
	python3-hawkey 	0.6.1-2.fc24 	> 	0.6.2-1.fc24
	libsolv 	0.6.14-1.fc24 	> 	0.6.14-2.fc24
	dnf-plugins-core 	0.1.12-3.fc24 	> 	0.1.13-1.fc24
	dnf-conf 	1.1.2-4.fc24 	> 	1.1.3-1.fc24
	libipt 	1.4.2-1.fc24 	> 	1.4.3-1.fc24
	ipcalc 	0.1.3-1.fc24 	> 	0.1.4-2.fc24
Comment 1 Peter Bieringer 2015-10-19 04:32:46 EDT
Confirmed on a local F24 build system, core dump analyzed, looks like unrelated to mod_ipv6calc and more a general problem of the new httpd version.

Bug already filed, let's wait for the result: https://bugzilla.redhat.com/show_bug.cgi?id=1272234 (httpd-2.4.17-2.fc24 segfaults: ap_mpm_pod_check (pod=0x0) at mpm_unix.c:459)
Comment 2 Jan Kurik 2016-02-24 10:51:09 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Peter Bieringer 2017-01-05 02:05:10 EST
Closed because related bug https://bugzilla.redhat.com/show_bug.cgi?id=1272234  was fixed, issue no longer seen

Note You need to log in before you can comment on or make changes to this bug.