This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1272901 - mod_perl-2.0.9-1.fc24 FTBFS: dependency on Test module not declared
mod_perl-2.0.9-1.fc24 FTBFS: dependency on Test module not declared
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mod_perl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Kaluža
Fedora Extras Quality Assurance
https://apps.fedoraproject.org/kosche...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 03:50 EDT by Petr Pisar
Modified: 2015-10-19 08:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-19 08:32:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-10-19 03:50:02 EDT
mod_perl-2.0.9-1.fc24 fails to build in F24 because tests fails:

+ /usr/bin/perl Makefile.PL PREFIX=/builddir/build/BUILDROOT/mod_perl-2.0.9-2.fc24.x86_64//usr INSTALLDIRS=vendor MP_APXS=/usr/bin/apxs MP_APR_CONFIG=/usr/bin/apr-1-config
Can't locate Test.pm in @INC (you may need to install the Test module) (@INC contains: lib Apache-Test/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at Apache-Test/lib/Apache/Test.pm line 24.

This is because Test module was moved from perl package to a separate package and mod_perl does not declare the dependency.
Comment 1 Jan Kaluža 2015-10-19 08:32:25 EDT
Fixed in rawhide

Note You need to log in before you can comment on or make changes to this bug.