Bug 127298 - ImageMagick's "identify -verbose" does not break printed line on empty strings in EXIF tag
ImageMagick's "identify -verbose" does not break printed line on empty string...
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libexif (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Matthias Clasen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-06 02:36 EDT by Moritz Barsnick
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-30 12:46:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moritz Barsnick 2004-07-06 02:36:49 EDT
Description of problem:
The program "identify" from the ImageMagick package prints certain 
info fields in its verbose output. Some seem to exist only if such 
fields are present in the image under investigation, such as 
variations of "Date and Time" (EXIF info??). It seems that if these 
fields exist but are empty in the image, the info line is printed, 
but not terminated with a "\n".

Version-Release number of selected component (if applicable):
ImageMagick-5.5.7.15-1.3

How reproducible:
with certain images

Steps to Reproduce:
1. identify -verbose IMG_1001.JPG | grep -C1 Date
2.
3.
  
Actual results:
    Resolution Unit: Inch
    Date and Time:     YCbCr Positioning: co-sited
    Compression: JPEG compression
--
    Exif Version: Exif Version 2.1
    Date and Time (original):     Date and Time (digitized):     
ComponentsConfiguration: Y Cb Cr -
    Compressed Bits per Pixel: 2/1

Expected results:
    Resolution Unit: Inch
    Date and Time:     
    YCbCr Positioning: co-sited
    Compression: JPEG compression
--
    Exif Version: Exif Version 2.1
    Date and Time (original):     
    Date and Time (digitized):     
    ComponentsConfiguration: Y Cb Cr -
    Compressed Bits per Pixel: 2/1


Additional info:
bugzilla wraps lines, sorry. I assume the sixth and seventh line of 
"actual results" should be merged (without myself being able to 
preview this report).

P.S.: ImageMagick-6.x is available. Rawhide, anyone?
Comment 1 Moritz Barsnick 2005-01-05 08:10:32 EST
These messages are from libexif, so I'm changing the affected 
component.

At a quick glance at libexif, I can't see why the code should behave 
this way. Perhaps ImageMagick-5.5.7.15-1.3 was built against a 
different version of libexif.

I currently can't reproduce this with any ImageMagick I have near me. 
Are the current ones not built against libexif anymore? 5.4.7-5 
wasn't (yet), and 6.0.7.1-4 isn't (anymore?). The mentioned version 
5.5.7.15-1.3 was though.
Comment 2 Moritz Barsnick 2005-08-31 12:47:02 EDT
May I, as thie original reporter, change this bug's status to WORKSFORME and 
close it?

I can't reproduce, I don't have (can't find) the image file that triggered this 
bug, and can't find the bug in the sources (albeit other versions though). And 
nothing has happened here for the last 13++ months. ;-)
Comment 3 Matthias Clasen 2006-07-30 12:46:33 EDT
ok, lets close this then.

Note You need to log in before you can comment on or make changes to this bug.