Bug 1273186 - [RHEV] Unable to perform VM SmartState Analysis when VM is down on NFS
[RHEV] Unable to perform VM SmartState Analysis when VM is down on NFS
Status: CLOSED DUPLICATE of bug 1095243
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.5.0
Assigned To: Rich Oliveri
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-19 17:20 EDT by Thom Carlin
Modified: 2015-12-21 07:27 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-06 18:57:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-10-19 17:20:14 EDT
Description of problem:

Performing a VM SmartState Analysis fails when the VM is down on NFS.  However, it succeed if the VM is up.

Version-Release number of selected component (if applicable):

5.4.3.1.20151013111241_1c155a5

How reproducible:

100%

Steps to Reproduce:
1. Define RHEV Provider
2. Provide Credentials
3. Refresh Relationships and Power States
4. Provide Host Credentials
5. Run a SmartState Analysis on a VM residing on NFS with host UP, VM down

Actual results:

Failure with "No active SmartProxy found to analyze this VM

Expected results:

Successful SmartState Analysis

Additional info:

May be due to using the Host the VM is running on to perform the SmartState Analysis when the VM is UP (Host = Nil if down).

The VM is part of a RHEV cluster.  From the cluster, can find the Hosts UP on that cluster and select one to perform the SmartState Analysis.
Comment 3 Rich Oliveri 2015-10-30 13:47:12 EDT
Thom, I haven't been able to reproduce this problem. For RHEV SSA, we never use the hosts, so that can't be the issue. Also, there should be no need to add credentials for the hosts.

The SmartProxy in question is the appliance itself. For RHEV, the SmartState role needs to be set on the appliance, and the appliance needs to reside in the same datacenter as the VMs being scanned. Is that the case in your environment?
Comment 4 Thom Carlin 2015-10-30 14:08:36 EDT
Rich,

Yes, the SmartState role was set and the appliance resided in the same datacenter.  I'll try to reproduce it.
Comment 5 Rich Oliveri 2015-11-06 18:57:50 EST

*** This bug has been marked as a duplicate of bug 1095243 ***
Comment 6 Thom Carlin 2015-12-21 07:27:02 EST
Closed as duplicate

Note You need to log in before you can comment on or make changes to this bug.