Bug 1273346 - [RHEV] Datastore SmartState Analysis returns complete but failure message in logs
[RHEV] Datastore SmartState Analysis returns complete but failure message in ...
Status: CLOSED DUPLICATE of bug 1208639
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: SmartState Analysis (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Rich Oliveri
Ilanit Stein
rhev:datastore:smartstate:ui
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 05:13 EDT by Thom Carlin
Modified: 2016-06-30 02:05 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-30 02:05:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thom Carlin 2015-10-20 05:13:23 EDT
Description of problem:

Performing datastore SmartState Analysis return "SmartState Analysis for 1 storages complete" [sic].  Examining the log shows "WARN -- : MIQ(Storage.smartstate_analysis) Storage [datastore_name] via Host [hostname]...Not Supported for HostRedhat"

Version-Release number of selected component (if applicable):

5.4.3.1.20151013111241_1c155a5

How reproducible:

100%

Steps to Reproduce:
1. Define RHEV Provider
2. Provide Provider Credentials
3. Refresh Relationships and Power States
4. Provide Host Credentials
5. Perform SmartState Analysis on Datastore

Actual results:

Datastore SmartState analysis job runs
Warning in logs: "WARN -- : MIQ(Storage.smartstate_analysis) Storage [datastore_name] via Host [hostname]...Not Supported for HostRedhat"
No SmartState data in datastore
Expected results:

No errors
SmartState data in datastore
OR
Consistent FC error when submitting: "MIQ(storage_controller-button): Datastore "datatstore_name": Error during 'scan': Action not supported for Datastore type [FCP], [datastore_name] with id: [datastore_id]

Additional info:

evm.log excerpt:
"WARN -- : MIQ(Storage.smartstate_analysis) Storage [datastore_name] via Host [hostname]...Not Supported for HostRedhat"
Comment 2 Yaniv Kaul 2016-06-07 18:45:28 EDT
Ilanit - can you check if there is any issue with SmartState analysis, specifically on FC based storage?
Comment 3 Ilanit Stein 2016-06-28 11:17:22 EDT
SmartState analysis is not available ("Perform SmartState Analysis" action is grayed out) within NFS/ISCSI datastore items.

checked on versions:
CFME-5.6.0.11-rc2.2.20160614152915_f315c68
RHEVM-3.6.6.2-0.1
Comment 4 Ilanit Stein 2016-06-29 03:32:40 EDT
In continue to comment #3 - FC 
SmartState analysis is not available ("Perform SmartState Analysis" action is grayed out) for FC datastore items as well.

checked on versions:
CFME-5.6.0.11-rc2.2.20160614152915_f315c68
RHEVM-3.6.6.2-0.1
Comment 5 Ilanit Stein 2016-06-30 02:05:55 EDT

*** This bug has been marked as a duplicate of bug 1208639 ***

Note You need to log in before you can comment on or make changes to this bug.