Bug 1273350 - No secondary navigations for 'Browse' on iPad
No secondary navigations for 'Browse' on iPad
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Steve Goodwin
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 05:19 EDT by yapei
Modified: 2015-11-23 16:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:13:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yapei 2015-10-20 05:19:36 EDT
Description of problem:
on iPad, no secondary nagivations when clicking 'Browse' on console.

Version-Release number of selected component (if applicable):
latest origin code
openshift v1.0.6-759-g403de38
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
etcd 2.1.2

How reproducible:
Always

Steps to Reproduce:
1.Create application
2.Click on 'Browse' on web console on iPad to check Builds,Services, Builds,Pods,Events,Route,ImageStreams info

Actual results:
Secondary menus don't appear when clicking on 'Browse'

Expected results:
Secondary menu Builds,Services,Builds,Pods,Events,Route,ImageStreams should appear, could select different resources

Additional info:
Comment 1 openshift-github-bot 2015-10-20 14:59:23 EDT
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/2a2fabebdea5669327c2f8629ed21927565dd845
Bug 1273350 - make click open the secondary nav instead of navigating
Comment 2 Jessica Forrester 2015-10-20 15:14:49 EDT
Changed the behavior of the actual  Browse link, click will now open/close the popup menu in addition to hover opening the menu.  So on ipad touch should open the menu.  This also fixes keyboard accessibility of accessing the secondary menu.
Comment 3 yapei 2015-10-21 01:35:35 EDT
Verified on latest origin code
oc v1.0.6-803-g7c12c7a
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4

Re-connect button and function works well in Firefox 41.0.1, Chrome 46.0.2490.71, IE 11.0.19, Mac Safari 9.0. 

But one minor issue:

for iPad, when switching to portrait mode, the re-connect button is adjusted to lower left corner.

for iPhone, the re-connect button is always in the lower left corner in both portrait and landscape mode.
Comment 4 yapei 2015-10-21 01:38:26 EDT
Sorry paste the comments in wrong place, pls ignore 'Comment 3', it's a comment for https://bugzilla.redhat.com/show_bug.cgi?id=1272827
Comment 5 yapei 2015-10-21 02:14:03 EDT
Verified on latest origin code
oc v1.0.6-803-g7c12c7a
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4

the issue is fixed, secondary menu could be open/close on click or hover

Note You need to log in before you can comment on or make changes to this bug.