Bug 1273484 - CentOS7 problem with gcc
CentOS7 problem with gcc
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gcc (Show other bugs)
7.0
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Jakub Jelinek
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 10:25 EDT by Daniel U. Thibault
Modified: 2015-10-21 04:18 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 04:18:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel U. Thibault 2015-10-20 10:25:59 EDT
Description of problem:

Unexpected gcc error during compilation of LTTng 2.7.0-stable lttng-modules (1f7d83a) on CentOS Linux release 7.1.1503 (Core) (64 bits), running kernel 3.10.0-229.7.2.el7

  CC [M]  /usr/src/lttng-modules-2.7.0-stable/lttng-syscalls.o
/usr/src/kernels/3.10.0-229.el7.x86_64/arch/x86/include/asm/current.h: Assembler messages:
/usr/src/kernels/3.10.0-229.el7.x86_64/arch/x86/include/asm/current.h:14: Warning: end of file not at end of a line; newline inserted
{standard input}:16215: Error: unknown pseudo-op: `.'
{standard input}: Error: open CFI at the end of file; missing .cfi_endproc directive
gcc: internal compiler error: Killed (program cc1)

/usr/src/kernels/3.10.0-229.el7.x86_64/arch/x86/include/asm/current.h is NOT truncated

Version-Release number of selected component (if applicable):

gcc (GCC) 4.8.3 20140911 (Red Hat 4.8.3-9)

How reproducible:

Very.

Steps to Reproduce:
1. Fetch http://git.lttng.org/?p=lttng-modules.git;a=snapshot;h=1f7d83a89fd4c975f0e3fccd55fa59e03527152e;sf=tgz (you may also need glib2-devel-2.40.0-4.el7, gtk2-devel-2.24.22-5.el7_0.1, ncurses-devel-5.9-13.20130511.el7, pango-devel-1.34.1-5.el7, popt-devel-1.13-16.el7, uuid-devel-1.6.2-26.el7)
2. Deploy the tar.gz to e.g. /usr/src/
3. From the deployment folder, run $ make &> make.log

Actual results:

The error quoted above.

Expected results:

Should compile.

Additional info:

I've compiled the same lttng-modules package on Ubuntu 12.04.5 without any issue (gcc Ubuntu/Linaro 4.6.3-1ubuntu5, kernel 3.9.3).
Comment 1 Marek Polacek 2015-10-20 10:28:48 EDT
This almost always means that the machine doesn't have enough memory and the OOM killer kills the cc1 process.
Comment 3 Daniel U. Thibault 2015-10-20 16:47:00 EDT
Indeed, increasing the virtual machine's memory solved the problem.

So I guess teh bug should be relabelled something like 'gcc should report out-of-memory errors in a more obvious way'. Because that error message was pretty well obfuscated.
Comment 4 Marek Polacek 2015-10-21 04:18:01 EDT
There's an upstream PR for this now:
https://gcc.gnu.org/bugzilla/show_bug.cgi?id=68038

I think we can close this bug now; please reopen if you have any further questions.

Note You need to log in before you can comment on or make changes to this bug.