Bug 1273516 - 0x00007fffd74f2f61 in run_vertex_stage (ctx=0x4c23c78, stage=<optimized out>) at tnl/t_vb_vertex.c:188
0x00007fffd74f2f61 in run_vertex_stage (ctx=0x4c23c78, stage=<optimized out>)...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
22
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-20 11:33 EDT by Germano Massullo
Modified: 2016-07-07 05:07 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-07 05:07:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Germano Massullo 2015-10-20 11:33:34 EDT
Description of problem:
In QtCreator when you open a qml file and you clic on Design tab, it will crash

$ gdb qtcreator
GNU gdb (GDB) Fedora 7.9.1-19.fc22
Copyright (C) 2015 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
Type "show configuration" for configuration details.
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>.
Find the GDB manual and other documentation resources online at:
<http://www.gnu.org/software/gdb/documentation/>.
For help, type "help".
Type "apropos word" to search for commands related to "word"...
Reading symbols from qtcreator...Reading symbols from /usr/lib/debug/usr/bin/qtcreator.debug...done.
done.
(gdb) run
Starting program: /usr/bin/qtcreator 
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib64/libthread_db.so.1".
[New Thread 0x7fffdd68e700 (LWP 12386)]
Detaching after fork from child process 12387.
Detaching after fork from child process 12388.
Detaching after fork from child process 12389.
Detaching after fork from child process 12390.
Detaching after fork from child process 12391.
Detaching after fork from child process 12393.
Detaching after fork from child process 12394.
Detaching after fork from child process 12396.
Detaching after fork from child process 12398.
Detaching after fork from child process 12399.
Detaching after fork from child process 12400.
Detaching after fork from child process 12402.
Detaching after fork from child process 12403.
Detaching after fork from child process 12405.
Detaching after fork from child process 12406.
Detaching after fork from child process 12407.
Detaching after fork from child process 12408.
Detaching after fork from child process 12409.
Detaching after fork from child process 12411.
Detaching after fork from child process 12414.
Detaching after fork from child process 12427.
Detaching after fork from child process 12428.
Detaching after fork from child process 12429.
Detaching after fork from child process 12433.
Detaching after fork from child process 12436.
Detaching after fork from child process 12438.
Detaching after fork from child process 12442.
Detaching after fork from child process 12447.
Detaching after fork from child process 12450.
Detaching after fork from child process 12456.
Detaching after fork from child process 12462.
Detaching after fork from child process 12463.
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
QQuickWidget cannot be used as a native child widget. Consider setting Qt::AA_DontCreateNativeWidgetSiblings
[New Thread 0x7fffb2ffe700 (LWP 12474)]
[New Thread 0x7fffb3fff700 (LWP 12426)]
[New Thread 0x7fffc8ffb700 (LWP 12425)]
[New Thread 0x7fffc9ffc700 (LWP 12424)]
[New Thread 0x7fffca7fd700 (LWP 12423)]
[New Thread 0x7fffd6a02700 (LWP 12422)]
[New Thread 0x7fffcaffe700 (LWP 12421)]
[New Thread 0x7fffcb7ff700 (LWP 12420)]
[New Thread 0x7fffdde8f700 (LWP 12385)]
[New Thread 0x7ffff05ec700 (LWP 12381)]

Program received signal SIGSEGV, Segmentation fault.
0x0000000000000000 in ?? ()
(gdb) backtrace
#0  0x0000000000000000 in  ()
#1  0x00007fffd74f2f61 in run_vertex_stage (ctx=0x4c23c78, stage=<optimized out>) at tnl/t_vb_vertex.c:188
#2  0x00007fffd74de2f2 in _tnl_run_pipeline (ctx=ctx@entry=0x4c23c78) at tnl/t_pipeline.c:241
#3  0x00007fffd765e95f in intelRunPipeline (ctx=0x4c23c78) at intel_tris.c:1097
#4  0x00007fffd74dd8fc in _tnl_draw_prims (ctx=0x4c23c78, prim=0x7fffffffccc0, nr_prims=1, ib=0x0, index_bounds_valid=<optimized out>, min_index=0, max_index=5, tfb_vertcount=0x0, indirect=0x0) at tnl/t_draw.c:519
#5  0x00007fffd74c2b6c in vbo_draw_arrays (ctx=0x4c23c78, mode=4, start=0, count=6, numInstances=1, baseInstance=0)
    at vbo/vbo_exec_array.c:645
#6  0x00000030fe232651 in QOpenGLTextureBlitterPrivate::blit(unsigned int, QMatrix4x4 const&, QGenericMatrix<3, 3, float> const&) (count=6, first=0, mode=4, this=<optimized out>) at ../../src/gui/opengl/qopenglfunctions.h:716
#7  0x00000030fe232651 in QOpenGLTextureBlitterPrivate::blit(unsigned int, QMatrix4x4 const&, QGenericMatrix<3, 3, float> const&) (this=0x3eead80, texture=15, vertexTransform=..., textureTransform=...) at opengl/qopengltextureblitter.cpp:200
#8  0x00000030fe232fc8 in QOpenGLTextureBlitter::blit(unsigned int, QMatrix4x4 const&, QGenericMatrix<3, 3, float> const&) (this=<optimized out>, texture=<optimized out>, targetTransform=..., sourceTransform=...) at opengl/qopengltextureblitter.cpp:361
#9  0x00000030fe19e9ff in blit(QPlatformTextureList const*, int, QWindow*, QRect const&, QOpenGLTextureBlitter*) (textures=textures@entry=0x64c540, idx=idx@entry=0, window=window@entry=0x4f927b0, deviceWindowRect=..., blitter=0x3ef9670)
    at painting/qplatformbackingstore.cpp:254
#10 0x00000030fe19f14e in QPlatformBackingStore::composeAndFlush(QWindow*, QRegion const&, QPoint const&, QPlatformTextureList*, QOpenGLContext*, bool) (this=this@entry=0x213cf40, window=window@entry=0x4f927b0, region=..., offset=..., textures=textures@entry=0x64c540, context=context@entry=0x5341310, translucentBackground=false) at painting/qplatformbackingstore.cpp:297
#11 0x00007ffff0c6dbc7 in QXcbBackingStore::composeAndFlush(QWindow*, QRegion const&, QPoint const&, QPlatformTextureList*, QOpenGLContext*, bool) (this=this@entry=0x213cf40, window=0x4f927b0, region=..., offset=..., textures=textures@entry=0x64c540, context=context@entry=0x5341310, translucentBackground=false) at qxcbbackingstore.cpp:418
#12 0x00000030feb5edeb in QWidgetBackingStore::qt_flush(QWidget*, QRegion const&, QBackingStore*, QWidget*, QPoint const&, QPlatformTextu---Type <return> to continue, or q <return> to quit---
reList*, QWidgetBackingStore*) (widget=0x4e575b0, region=..., backingStore=<optimized out>, tlw=<optimized out>, tlwOffset=..., widgetTextures=0x64c540, widgetBackingStore=0x213d060) at kernel/qwidgetbackingstore.cpp:114
#13 0x00000030feb62597 in QWidgetBackingStore::sync(QWidget*, QRegion const&) (this=0x213d060, exposedWidget=0x4e575b0, exposedRegion=...) at kernel/qwidgetbackingstore.cpp:945

#14 0x00000030febb4243 in QWidgetWindow::event(QEvent*) (this=0x4f927b0, event=0x7fffffffd400) at kernel/qwidgetwindow.cpp:255
#15 0x00000030feb544ac in QApplicationPrivate::notify_helper(QObject*, QEvent*) (this=0x630160, receiver=0x4f927b0, e=0x7fffffffd400)
    at kernel/qapplication.cpp:3717
#16 0x00000030feb59976 in QApplication::notify(QObject*, QEvent*) (this=0x7fffffffdcf0, receiver=0x4f927b0, e=0x7fffffffd400)
    at kernel/qapplication.cpp:3500
#17 0x00000030fd48361b in QCoreApplication::notifyInternal(QObject*, QEvent*) (this=0x7fffffffdcf0, receiver=receiver@entry=0x4f927b0, event=event@entry=0x7fffffffd400) at kernel/qcoreapplication.cpp:965
#18 0x00000030fdef0abc in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) (event=0x7fffffffd400, receiver=0x4f927b0) at ../../src/corelib/kernel/qcoreapplication.h:227
#19 0x00000030fdef0abc in QGuiApplicationPrivate::processExposeEvent(QWindowSystemInterfacePrivate::ExposeEvent*) (e=0x9fdf730)
    at kernel/qguiapplication.cpp:2643
#20 0x00000030fdef183d in QGuiApplicationPrivate::processWindowSystemEvent(QWindowSystemInterfacePrivate::WindowSystemEvent*) (e=e@entry=0x9fdf730) at kernel/qguiapplication.cpp:1644
#21 0x00000030fded55d8 in QWindowSystemInterface::sendWindowSystemEvents(QFlags<QEventLoop::ProcessEventsFlag>) (flags=...)
    at kernel/qwindowsysteminterface.cpp:608
#22 0x00007ffff0c7fe80 in userEventSourceDispatch(GSource*, GSourceFunc, gpointer) (source=<optimized out>)
    at eventdispatchers/qeventdispatcher_glib.cpp:70
#23 0x000000357e249a8a in g_main_context_dispatch (context=0x7fffe80016f0) at gmain.c:3122
#24 0x000000357e249a8a in g_main_context_dispatch (context=context@entry=0x7fffe80016f0) at gmain.c:3737
#25 0x000000357e249e20 in g_main_context_iterate (context=context@entry=0x7fffe80016f0, block=block@entry=1, dispatch=dispatch@entry=1, s---Type <return> to continue, or q <return> to quit---
elf=<optimized out>) at gmain.c:3808
#26 0x000000357e249ecc in g_main_context_iteration (context=0x7fffe80016f0, may_block=may_block@entry=1) at gmain.c:3869
#27 0x00000030fd4d9d8f in QEventDispatcherGlib::processEvents(QFlags<QEventLoop::ProcessEventsFlag>) (this=0x696a20, flags=...)
    at kernel/qeventdispatcher_glib.cpp:418
#28 0x00000030fd480daa in QEventLoop::exec(QFlags<QEventLoop::ProcessEventsFlag>) (this=this@entry=0x7fffffffd6c0, flags=..., 
    flags@entry=...) at kernel/qeventloop.cpp:204
#29 0x00000030fd488e6c in QCoreApplication::exec() () at kernel/qcoreapplication.cpp:1229
#30 0x00000030fdee724c in QGuiApplication::exec() () at kernel/qguiapplication.cpp:1528
#31 0x00000030feb508e5 in QApplication::exec() () at kernel/qapplication.cpp:2977
#32 0x0000000000409016 in main(int, char**) (argc=1, argv=<optimized out>) at main.cpp:521
(gdb)
Comment 1 Sandro Mani 2015-10-21 04:48:55 EDT
Looks like a crash in mesa.
Comment 2 Igor Gnatenko 2016-07-07 05:07:17 EDT
This is very old bug, if you still can reproduce it - please reopen.

Note You need to log in before you can comment on or make changes to this bug.