Bug 127362 - Comment character "#" after whitespace ignored in yum.conf
Summary: Comment character "#" after whitespace ignored in yum.conf
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: python   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mihai Ibanescu
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-07 04:29 UTC by Per Nystrom
Modified: 2014-01-21 22:49 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-11 00:42:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum.conf snippets (1.01 KB, text/plain)
2004-07-07 04:33 UTC, Per Nystrom
no flags Details

Description Per Nystrom 2004-07-07 04:29:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
See attachment; this form goofs it up.  Look at the difference between
the section marked ## WORKS ## and the section marked ## FAILS ##.


Version-Release number of selected component (if applicable):
yum-2.0.7-1.1

How reproducible:
Always

Steps to Reproduce:
1.  Use "#" comment character after leading whitespace in yum.conf


Additional info:

Comment 1 Per Nystrom 2004-07-07 04:33:02 UTC
Created attachment 101673 [details]
yum.conf snippets

Comment 2 Seth Vidal 2004-07-07 04:34:33 UTC
the config parser in yum uses python's configparser module.

converting this over to a python bug.


Comment 3 Seth Vidal 2004-07-11 00:42:17 UTC
Actually, I looked this up

this is not a bug in Configparser or python or even in yum.

it is intended behavior

whitespace  at the beginning of a line marks a line continuation.




Note You need to log in before you can comment on or make changes to this bug.