Bug 127366 - Missing documentation for redhat-ready tests
Missing documentation for redhat-ready tests
Status: CLOSED WORKSFORME
Product: Red Hat Ready Certification Tests
Classification: Retired
Component: rhr2 (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Rob Landry
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-07-07 03:57 EDT by Rainer Koenig
Modified: 2007-04-18 13:09 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-13 07:02:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rainer Koenig 2004-07-07 03:57:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040614 Firefox/0.8

Description of problem:
I'm trying to do a "Red Hat Ready" certification for some PCs. For
that I've downloaded the scripts from
http://hardware.redhat.com/hcl/?pagename=files

That gives the following files:
rhr2-0.9-14.2.noarch.rpm
rhr2-externals-0.9-14.2.noarch.rpm
rhr2-tests-0.9-14.2.noarch.rpm

I installed those files on a Red Hat Enterprise Linux 3 WS Update 2
that was installed selecting "ALL" packages. After that I can start 

# readhat-ready 

and get a sort of menu system. The problem starts with the hardware
detection. The system is busy for a while, but if I look into 
/etc/rhr/hardware.conf then I only see a bunch of comments and 
nothing else. 

Since there is no documentation for the format of this files I think
that I should enter here some information by hand. If I play around
with the tests for example the CDROM test is finished very quickly 
and doesn't access the CD drive at all. The CORE test is running 
long without any visible results. The USB test seems to hang in
an endless loop where it tells me to plug and unplug devices and
so on.

Is there somewhere a sort of HowTo, step-by-step user documentation
or anything helpful for this certification tests? I'm not much 
motivated to have a close look at the scripts just to figure out
what data could be needed by the scripts.


Version-Release number of selected component (if applicable):
0.9-14.2

How reproducible:
Always

Steps to Reproduce:
1. Download files
2. Install the 3 rpms
3. run redhat-ready
    

Actual Results:  Hardware detection seems not to work. Undocumented
format of /etc/rhr/hardware.conf doesn't make the job easier. 

Expected Results:  Working hardware detection or documentation of
vital files. 

Additional info:
Comment 1 Rob Landry 2004-07-12 22:26:49 EDT
The normal cause is an inability of the test machine to reach
xmlrpc.rhn.redhat.com which is required by hardware.py which is used
during the discovery phase.  Simply ensuring that any sort of web
server responds to this address (for example adding 127.0.0.1
xmlrpc.rhn.redhat.com and ensure httpd is running locally) should
resolve this issue.  hardware.conf is self documented; unfortunately
that's based on redhat-ready's ability to create it in the first
place.  Perhaps a sample file would assist here.  Some documentation
is available in /usr/share/doc/rhr2-0.9 but I don't think its what
you're looking for.  A work around is expected to be in the next
release of rhr2 and perhaps I could the afore mentioned sample file then.
Comment 2 Rob Landry 2004-07-12 22:29:24 EDT
that is to say...

- xmlrpc.rhn.redhat.com and ensure httpd is running locally) should
+ xmlrpc.rhn.redhat.com to /etc/hosts and ensure httpd is running
locally) should

...and...

- release of rhr2 and perhaps I could the afore mentioned sample file
then.
+ release of rhr2 and perhaps I could add the afore mentioned sample
file then.
Comment 3 Rainer Koenig 2004-07-13 07:02:52 EDT
Thanks for the hint with the xmlrpc.rhn.redhat.com.
/etc/rhr/hardware.conf looks much better now, that means I can go on
testing a bit. 

Note You need to log in before you can comment on or make changes to this bug.