Bug 1273705 - JBoss images are using the old image name in imagestream installed by ansible
JBoss images are using the old image name in imagestream installed by ansible
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Scott Dodson
Ma xiaoqiang
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 01:22 EDT by Wang Haoran
Modified: 2016-07-03 20:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-20 10:41:22 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wang Haoran 2015-10-21 01:22:52 EDT
Description of problem:

JBoss related imagestream are not correctly installed, it is still using old image names, not the updated names like 
https://github.com/jboss-openshift/application-templates/blob/master/jboss-image-streams.json
Version-Release number of selected component (if applicable):
openshift v3.0.2.901-61-g568adb6
kubernetes v1.1.0-alpha.1-653-g86b4e77
oc v3.0.2.901-61-g568adb6

How reproducible:
always

Steps to Reproduce:
1.install the ose env
2.oc get is -n openshift

Actual results:
[vagrant@ose secrets]$ oc get is -n openshift
NAME                                 DOCKER REPO                                                      TAGS                                     UPDATED
jboss-amq-6                          registry.access.redhat.com/jboss-amq-6/amq-openshift             6.2-84,6.2-123,latest + 2 more...        About an hour ago
jboss-eap6-openshift                 registry.access.redhat.com/jboss-eap-6/eap-openshift             6.4-239,6.4-207,6.4-260 + 2 more...      About an hour ago
jboss-webserver3-tomcat7-openshift   registry.access.redhat.com/jboss-webserver-3/tomcat7-openshift   3.0,3.0-190,latest + 2 more...           About an hour ago
jboss-webserver3-tomcat8-openshift   registry.access.redhat.com/jboss-webserver-3/tomcat8-openshift   3.0-163,3.0-137,3.0-190 + 2 more...      About an hour ago

Expected results:
after release should be :
NAME                                  DOCKER REPO                                                                  TAGS      UPDATED
jboss-amq-6                           registry.access.redhat.com/jboss-amq-6/amq62-openshift                                 
jboss-amq-62                          registry.access.redhat.com/jboss-amq-6/amq62-openshift                                 
jboss-eap64-openshift                 registry.access.redhat.com/jboss-eap-6/eap64-openshift                                 
jboss-webserver30-tomcat7-openshift   registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat7-openshift             
jboss-webserver30-tomcat8-openshift   registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift          

Additional info:
Comment 2 XiuJuan Wang 2015-10-21 05:41:14 EDT
The jboss template under openshift are too old,should create from https://github.com/jboss-openshift/application-templates/tree/master/webserver
Comment 3 Jason DeTiberus 2015-10-22 16:21:07 EDT
Scott,

Not sure if your recent changes have already addressed this or not.
Comment 4 Scott Dodson 2015-10-22 16:59:09 EDT
It does not and we're not to update those until that team tags their release.

I guess we can leave this bug open as a reminder to update them but that team should be notifying me when they're ready.
Comment 5 Wenjing Zheng 2015-10-23 06:47:23 EDT
Copied XPass QE tschloss to this bug.
Comment 6 Scott Dodson 2015-11-02 16:20:36 EST
Fixed via https://github.com/openshift/openshift-ansible/pull/781

To test
git checkout -b bz1273705
git pull https://github.com/sdodson/openshift-ansible xpaas-1.1

then re-run your install.
Comment 7 Wang Haoran 2015-11-03 01:55:48 EST
verified with this pr , should merge after image delivered. there are no tags for the is currently because the images are not delivered.

let's make this bug open, after pr merged, I will change the status of the bug.
Comment 8 Johnny Liu 2015-11-03 06:55:00 EST
According to comment 6, verified this bug, and PASS.


# oc get is -n openshift
NAME                                  DOCKER REPO                                                                  TAGS                                     UPDATED
jboss-amq-6                           registry.access.redhat.com/jboss-amq-6/amq-openshift                         6.2,6.2-84,latest + 2 more...            48 minutes ago
jboss-amq-62                          registry.access.redhat.com/jboss-amq-6/amq62-openshift                                                                
jboss-eap6-openshift                  registry.access.redhat.com/jboss-eap-6/eap-openshift                         6.4-239,6.4-207,6.4 + 2 more...          48 minutes ago
jboss-eap64-openshift                 registry.access.redhat.com/jboss-eap-6/eap64-openshift                                                                
jboss-webserver3-tomcat7-openshift    registry.access.redhat.com/jboss-webserver-3/tomcat7-openshift               3.0-190,latest,3.0 + 2 more...           49 minutes ago
jboss-webserver3-tomcat8-openshift    registry.access.redhat.com/jboss-webserver-3/tomcat8-openshift               3.0-163,3.0-137,3.0 + 2 more...          48 minutes ago
jboss-webserver30-tomcat7-openshift   registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat7-openshift                                            
jboss-webserver30-tomcat8-openshift   registry.access.redhat.com/jboss-webserver-3/webserver30-tomcat8-openshift

Note You need to log in before you can comment on or make changes to this bug.