Bug 1273708 - Still show --all=true in oc export help page after the flag --all has been deprecated
Still show --all=true in oc export help page after the flag --all has been de...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 01:43 EDT by Yan Du
Modified: 2016-05-12 13:11 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-12 13:11:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Du 2015-10-21 01:43:39 EDT
Description of problem:
# oc export svc --all > 1.json
Flag --all has been deprecated, all is ignored because specifying a resource without a name selects all the instances of that resource

And check the help page:
Options:
      --all=true: Select all resources in the namespace of the specified resource types


Version-Release number of selected component (if applicable):
openshift v3.0.2.901-61-g568adb6
kubernetes v1.1.0-alpha.1-653-g86b4e77

How reproducible:
always

Steps to Reproduce:
1. Check the help page of oc export cmd


Actual results:
As description


Expected results:
Should remove the --all=true option infomation in help page, since flag --all has been deprecated
Comment 1 Fabiano Franz 2016-01-11 15:22:38 EST
Fixed in https://github.com/openshift/origin/pull/6610
Comment 2 openshift-github-bot 2016-01-12 11:46:11 EST
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/08ed35ca0238e73ed71e95a0224bb1441e2fd6c7
Bug 1273708 - mark --all in oc export deprecated in help
Comment 3 Yan Du 2016-01-13 01:51:02 EST
Test on devenv_rhel7_3131, bug have been fixed.

Options:
      --all=true: DEPRECATED: all is ignored, specifying a resource without a name selects all the instances of that resource

Move to verified.

Note You need to log in before you can comment on or make changes to this bug.