Bug 127371 - cron appears to lose access to crontabs
Summary: cron appears to lose access to crontabs
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: policy   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Russell Coker
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-07-07 10:40 UTC by Nigel Metheringham
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-06 06:58:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nigel Metheringham 2004-07-07 10:40:32 UTC
Description of problem:

Box which was running FC1 upgraded to FC2, cron stopped working
correctly - jobs not being run.

Errors in /var/log/cron on cron startup like:-
  crond[3753]: (system_u) getfilecon FAILED (/etc/crontab) 
  crond[3753]: (nigel) getfilecon FAILED (cron/nigel) 
  crond[3753]: (root) getfilecon FAILED (cron/root) 

I suspect, without having investigated carefully that this worked OK
with the updated install kernel 2.6.6-1.435.i586 but failed on kernel
updates kernel 2.6.6-1.435.2.1.i586 and later - however this may be
due to the policy package not being installed until after the boot to
2.6.6-1.435

I've now disabled selinux to work around this problem.

Comment 1 tony 2004-08-08 11:35:30 UTC
I've had this problem too. It seemed to be induced on my
mail/webserver when I installed installed the SQL packages. 

It worked fine before that. 

Did the work around described here: 
http://www.redhat.com/archives/fedora-test-list/2004-May/msg01355.html

Seems to be working ok now.

For further info, mail me at tony1@aeran.info



Comment 2 Daniel Walsh 2004-11-06 06:58:27 UTC
Cron is working fine in FC3 with selinux-policy-strict-1.18.1 or greater


Note You need to log in before you can comment on or make changes to this bug.