Bug 1273791 - NetKVM: Do not touch control queue before status VIRTIO_CONFIG_S_DRIVER_OK is raised
NetKVM: Do not touch control queue before status VIRTIO_CONFIG_S_DRIVER_OK is...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Yan Vugenfirer
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 05:01 EDT by Yan Vugenfirer
Modified: 2017-01-06 01:57 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-01-06 01:57:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yan Vugenfirer 2015-10-21 05:01:09 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Yan Vugenfirer 2015-10-21 05:04:41 EDT
Description:

Such behaviour was acceptable before virtio 1.0. Should be fixed in order to comply to virtio 1.0.
Comment 2 Yan Vugenfirer 2015-10-21 08:21:19 EDT
In order to test, please run HCK on following platforms and check that there are no regressions (don't forget to use qxl driver and enable Power Management):

* Windows 7 32bit
* Window 2012R2
* Windows 10 64bit

Both multi-queue and single queue configurations should be tested.
Comment 4 Yu Wang 2016-01-13 03:16:14 EST
(In reply to Yan Vugenfirer from comment #2)
> In order to test, please run HCK on following platforms and check that there
> are no regressions (don't forget to use qxl driver and enable Power
> Management):
> 
> * Windows 7 32bit
> * Window 2012R2
> * Windows 10 64bit
> 
> Both multi-queue and single queue configurations should be tested.

Hi Yan

  I want to confirm that if qxl is a must configure for all the WHQL jobs? If so, why we use qxl to test, since usually we use vnc to test the jobs except one PM Job(PM PowerStateTransition)
  Now, we encountered a problem(Both multi-queue and single queue), 2012R2 guest always get stuck when run many jobs w/ qxl driver and enable PM. If qxl is not a must ,QE will use vnc to test WHQL jobs for 2012R2 guest.

Thanks
wyu
Comment 5 Yan Vugenfirer 2016-01-13 03:35:32 EST
(In reply to wangyu from comment #4)
> (In reply to Yan Vugenfirer from comment #2)
> > In order to test, please run HCK on following platforms and check that there
> > are no regressions (don't forget to use qxl driver and enable Power
> > Management):
> > 
> > * Windows 7 32bit
> > * Window 2012R2
> > * Windows 10 64bit
> > 
> > Both multi-queue and single queue configurations should be tested.
> 
> Hi Yan
> 
>   I want to confirm that if qxl is a must configure for all the WHQL jobs?
> If so, why we use qxl to test, since usually we use vnc to test the jobs
> except one PM Job(PM PowerStateTransition)
>   Now, we encountered a problem(Both multi-queue and single queue), 2012R2
> guest always get stuck when run many jobs w/ qxl driver and enable PM. If
> qxl is not a must ,QE will use vnc to test WHQL jobs for 2012R2 guest.
> 
> Thanks
> wyu

Hi Wyu,

QXL driver is only a must for the client OS versions (Windows 7, Windows 8, Windows 8.1, Widnows 10). Because on the client OSes we should support power managment.

For servers we don't have to use QXL during certification. 
We can choose to use it for our internal testing.

So no need for QXL on Windows 2012R2 server certification.
Comment 6 Yu Wang 2016-01-13 04:07:55 EST
(In reply to Yan Vugenfirer from comment #5)
> (In reply to wangyu from comment #4)
> > (In reply to Yan Vugenfirer from comment #2)
> > > In order to test, please run HCK on following platforms and check that there
> > > are no regressions (don't forget to use qxl driver and enable Power
> > > Management):
> > > 
> > > * Windows 7 32bit
> > > * Window 2012R2
> > > * Windows 10 64bit
> > > 
> > > Both multi-queue and single queue configurations should be tested.
> > 
> > Hi Yan
> > 
> >   I want to confirm that if qxl is a must configure for all the WHQL jobs?
> > If so, why we use qxl to test, since usually we use vnc to test the jobs
> > except one PM Job(PM PowerStateTransition)
> >   Now, we encountered a problem(Both multi-queue and single queue), 2012R2
> > guest always get stuck when run many jobs w/ qxl driver and enable PM. If
> > qxl is not a must ,QE will use vnc to test WHQL jobs for 2012R2 guest.
> > 
> > Thanks
> > wyu
> 
> Hi Wyu,
> 
> QXL driver is only a must for the client OS versions (Windows 7, Windows 8,
> Windows 8.1, Widnows 10). Because on the client OSes we should support power
> managment.
> 
> For servers we don't have to use QXL during certification. 
> We can choose to use it for our internal testing.
> 
> So no need for QXL on Windows 2012R2 server certification.

Hi Yan,

Thanks for your reply.

Additional question to confirm:
QE have usually used vnc to test the WHQL jobs except PM Jobs for client OS during certification. In other words,  we only use qxl to test the PM jobs not for all the jobs, is that acceptable?

BR
Wyu
Comment 7 Yan Vugenfirer 2016-01-13 04:55:59 EST
(In reply to wangyu from comment #6)
> (In reply to Yan Vugenfirer from comment #5)
> > (In reply to wangyu from comment #4)
> > > (In reply to Yan Vugenfirer from comment #2)
> > > > In order to test, please run HCK on following platforms and check that there
> > > > are no regressions (don't forget to use qxl driver and enable Power
> > > > Management):
> > > > 
> > > > * Windows 7 32bit
> > > > * Window 2012R2
> > > > * Windows 10 64bit
> > > > 
> > > > Both multi-queue and single queue configurations should be tested.
> > > 
> > > Hi Yan
> > > 
> > >   I want to confirm that if qxl is a must configure for all the WHQL jobs?
> > > If so, why we use qxl to test, since usually we use vnc to test the jobs
> > > except one PM Job(PM PowerStateTransition)
> > >   Now, we encountered a problem(Both multi-queue and single queue), 2012R2
> > > guest always get stuck when run many jobs w/ qxl driver and enable PM. If
> > > qxl is not a must ,QE will use vnc to test WHQL jobs for 2012R2 guest.
> > > 
> > > Thanks
> > > wyu
> > 
> > Hi Wyu,
> > 
> > QXL driver is only a must for the client OS versions (Windows 7, Windows 8,
> > Windows 8.1, Widnows 10). Because on the client OSes we should support power
> > managment.
> > 
> > For servers we don't have to use QXL during certification. 
> > We can choose to use it for our internal testing.
> > 
> > So no need for QXL on Windows 2012R2 server certification.
> 
> Hi Yan,
> 
> Thanks for your reply.
> 
> Additional question to confirm:
> QE have usually used vnc to test the WHQL jobs except PM Jobs for client OS
> during certification. In other words,  we only use qxl to test the PM jobs
> not for all the jobs, is that acceptable?
> 
> BR
> Wyu

The questions is how the test client is configured. 

1. Do you configure it for QXL and connect with VNC and QXL ?

or 

2. Do you re-run VM with QXL for PM tests?

The second option is grey zone - as the configuration of test client shouldn't change between tests.
Comment 8 Yu Wang 2016-01-13 05:08:33 EST
(In reply to Yan Vugenfirer from comment #7)
> (In reply to wangyu from comment #6)
> > (In reply to Yan Vugenfirer from comment #5)
> > > (In reply to wangyu from comment #4)
> > > > (In reply to Yan Vugenfirer from comment #2)
> > > > > In order to test, please run HCK on following platforms and check that there
> > > > > are no regressions (don't forget to use qxl driver and enable Power
> > > > > Management):
> > > > > 
> > > > > * Windows 7 32bit
> > > > > * Window 2012R2
> > > > > * Windows 10 64bit
> > > > > 
> > > > > Both multi-queue and single queue configurations should be tested.
> > > > 
> > > > Hi Yan
> > > > 
> > > >   I want to confirm that if qxl is a must configure for all the WHQL jobs?
> > > > If so, why we use qxl to test, since usually we use vnc to test the jobs
> > > > except one PM Job(PM PowerStateTransition)
> > > >   Now, we encountered a problem(Both multi-queue and single queue), 2012R2
> > > > guest always get stuck when run many jobs w/ qxl driver and enable PM. If
> > > > qxl is not a must ,QE will use vnc to test WHQL jobs for 2012R2 guest.
> > > > 
> > > > Thanks
> > > > wyu
> > > 
> > > Hi Wyu,
> > > 
> > > QXL driver is only a must for the client OS versions (Windows 7, Windows 8,
> > > Windows 8.1, Widnows 10). Because on the client OSes we should support power
> > > managment.
> > > 
> > > For servers we don't have to use QXL during certification. 
> > > We can choose to use it for our internal testing.
> > > 
> > > So no need for QXL on Windows 2012R2 server certification.
> > 
> > Hi Yan,
> > 
> > Thanks for your reply.
> > 
> > Additional question to confirm:
> > QE have usually used vnc to test the WHQL jobs except PM Jobs for client OS
> > during certification. In other words,  we only use qxl to test the PM jobs
> > not for all the jobs, is that acceptable?
> > 
> > BR
> > Wyu
> 
> The questions is how the test client is configured. 
> 
> 1. Do you configure it for QXL and connect with VNC and QXL ?
> 
> or 
> 
> 2. Do you re-run VM with QXL for PM tests?
> 
> The second option is grey zone - as the configuration of test client
> shouldn't change between tests.

Actually, we use the second to test WHQL jobs.
Comment 10 Yu Wang 2016-07-08 02:33:43 EDT
Hi,

According to comment#47 in bz 1190960 

Verified this issue with virtio-win-prewhql-0.1-121

Test passed With single queue & multiqueue:
"NDISTest 6.0 - [2 Machine]- 2c_Mini6RSSSendRecv" -Win7-32 
"NDISTest 6.0 - [2 Machine]- 2c_Mini6RSSSendRecv" -Win7-64 
"NDISTest 6.0 - [2 Machine]- 2c_Mini6RSSSendRecv (Multi-Group Win8+)" -Win2012R2

According to above, the issue has been fixed.


Thanks
Yu Wang
Comment 11 lijin 2016-07-31 22:59:29 EDT
change status to verified according to comment#10
Comment 12 lijin 2017-01-06 01:57:39 EST
close as this issue has already been fixed in rhel7.3 virtio-win package

Note You need to log in before you can comment on or make changes to this bug.