Bug 1273804 - Get 403 error when access "View Log" link on overview page
Get 403 error when access "View Log" link on overview page
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Management Console (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: bpeterse
yapei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 05:31 EDT by Wei Sun
Modified: 2015-11-23 16:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:17:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wei Sun 2015-10-21 05:31:51 EDT
Description of problem:
Start build and then browse overview page,click "View Log" on overview page,but get 403 error.

Version-Release number of selected component (if applicable):
devenv-rhel_2504

How reproducible:
Always

Steps to Reproduce:
1.Start build
2.Browse the overview page
3.Click "View Log"

Actual results:
3.Go to "project/wsuntest/browse/builds/nd/nd-1?tab=logs" , but get 403 error.
{
  "kind": "Status",
  "apiVersion": "v1",
  "metadata": {},
  "status": "Failure",
  "message": "User \"system:anonymous\" cannot \"get\" on \"/project/wsuntest/browse/builds/nd/nd-1\"",
  "reason": "Forbidden",
  "details": {},
  "code": 403
}

Expected results:
Should view logs

Additional info:
Comment 1 Jessica Forrester 2015-10-21 08:40:53 EDT
Duplicate of this github issue https://github.com/openshift/origin/issues/5264
Comment 2 Wei Sun 2015-10-28 23:27:33 EDT
Verified on devenv-rhel7_2583

Now the "View Log" is pointing to logs page

Note You need to log in before you can comment on or make changes to this bug.