Bug 1273824 - Failed to run softhsm2-util
Failed to run softhsm2-util
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: softhsm (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Spacek
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 06:43 EDT by Abhijeet Kasurde
Modified: 2015-10-21 08:18 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-21 08:11:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Abhijeet Kasurde 2015-10-21 06:43:22 EDT
Description of problem:
If user tries to run following command, then command triggers following error

# PKCS11SPY=/usr/lib64/pkcs11/libsofthsm2.so /usr/bin/softhsm2-util --init-token --slot 0 --label ipaDNSSEC --pin XXXXXXXX --so-pin XXXXXXXX
ERROR: Could not load the library: /usr/lib64/pkcs11/libsofthsm2.so: symbol EVP_aes_192_wrap, version libcrypto.so.10 not defined in file libcrypto.so.10 with link time reference
# echo $?
1


Version-Release number of selected component (if applicable):
softhsm-2.0.0rc1-3.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. PKCS11SPY=/usr/lib64/pkcs11/libsofthsm2.so /usr/bin/softhsm2-util --init-token --slot 0 --label ipaDNSSEC --pin XXXXXXXX --so-pin XXXXXXXX


Actual results:
Unable to run due to above mentioned error

Expected results:
Command should be successful.
Comment 2 Petr Spacek 2015-10-21 08:11:31 EDT
I'm unable to reproduce the problem with latest builds:
softhsm-2.0.0rc1-3.el7.x86_64
openssl-1.0.1e-42.el7_1.9.x86_64
ipa-4.2.0-15.el7

I double-checked errata and all these builds are slated for RHEL 7.2 release. For this reason I'm going to close this, feel free to re-open the bug if you manage to reproduce it. Thank you!

Note You need to log in before you can comment on or make changes to this bug.