Bug 1273875 - Kerberized NFS server docs errors
Kerberized NFS server docs errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: doc-Linux_Domain_Identity_Management_Guide (Show other bugs)
7.1
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Aneta Šteflová Petrová
Namita Soman
: Documentation, EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 08:35 EDT by Aneta Šteflová Petrová
Modified: 2015-11-19 10:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 10:26:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aneta Šteflová Petrová 2015-10-21 08:35:19 EDT
Section 16.3 Setting up a Kerberized NFS server contains incorrect commands, as reported by Jason E Parks:

-----

This guide indicates that nfs should be started as such: 

[root@nfs-server ~]# systemctl restart rpcsvcgssd.service

Unfortunately, this service does not exist in RHEL 7. [...] there IS an rpc-svcgssd.service. So should be: 

[root@nfs-server ~]# systemctl restart rpc-svcgssd.service


Section 16.3.2 is also incorrect. 

[root@nfs-client-server ~]# systemctl start rpcgssd.service
[root@nfs-client-server ~]# systemctl start rpcbind.service
[root@nfs-client-server ~]# systemctl start rpcidmapd.service

Should be 

[root@nfs-client-server ~]# systemctl start rpc-gssd.service
[root@nfs-client-server ~]# systemctl start rpcbind.service
[root@nfs-client-server ~]# systemctl start nfs-idmapd.service

----
Comment 1 Aneta Šteflová Petrová 2015-11-02 07:17:13 EST
I've asked the developers to review the systemctl commands.
Comment 2 Aneta Šteflová Petrová 2015-11-12 11:17:18 EST
Changes in 16.3.1. Setting up a Kerberized NFS Server, step 9:
* Removed "systemctl restart rpcsvcgssd.service" because "systemctl restart nfs-secure-server.service" (the command above) is an alias for it.

16.3.2. Setting up a Kerberized NFS Client, step 4:
* Replaced the previous systemctl commands as suggested in comment#0

Note You need to log in before you can comment on or make changes to this bug.