Bug 1273885 - Random uuid generated when trying to create new authentication key for cinder external provider
Random uuid generated when trying to create new authentication key for cinder...
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: BLL.Storage (Show other bugs)
3.6.0.1
Unspecified Unspecified
low Severity low (vote)
: ovirt-3.6.1
: 3.6.1
Assigned To: Daniel Erez
Eyal Shenitzky
storage
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 08:54 EDT by Eyal Shenitzky
Modified: 2016-07-13 00:56 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-22 08:28:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
amureini: ovirt‑3.6.z?
amureini: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
engine log (757.67 KB, application/x-gzip)
2015-10-21 08:54 EDT, Eyal Shenitzky
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 48107 master MERGED webadmin: new key dialog - tool-tip for UUID text-box Never
oVirt gerrit 48126 ovirt-engine-3.6 MERGED webadmin: new key dialog - tool-tip for UUID text-box Never

  None (edit)
Description Eyal Shenitzky 2015-10-21 08:54:29 EDT
Created attachment 1085119 [details]
engine log

Description of problem:

When creating new authentication key for cinder external provider,
Random uuid is not suppose to be generated.
This should prompt the already existing uuid in the system or blank field to be filled.  
 


Version-Release number of selected component (if applicable):

engine-version:3.6.0.1-0.1.el6


How reproducible:
100%

Steps to Reproduce:
1.Create cinder external provider
2.Enter new authentication key

Actual results:
Random uuid is generated.

Expected results:
should prompt the already existing uuid in the system or blank field to be filled.

Additional info:
relevant log time: ~Oct 21, 2015 11:59:35 AM
Comment 1 Yaniv Lavi 2015-10-22 04:07:20 EDT
What UUID are you referring to?
What is the impact to the user of this issue?
Comment 2 Allon Mureinik 2015-10-26 09:23:32 EDT
(In reply to eyal shenitzky from comment #0)
> Created attachment 1085119 [details]
> engine log
> 
> Description of problem:
> 
> When creating new authentication key for cinder external provider,
> Random uuid is not suppose to be generated.
> This should prompt the already existing uuid in the system or blank field to
> be filled.  
Not sure this is correct. Daniel?
Comment 3 Daniel Erez 2015-10-26 09:33:58 EDT
(In reply to Allon Mureinik from comment #2)
> (In reply to eyal shenitzky from comment #0)
> > Created attachment 1085119 [details]
> > engine log
> > 
> > Description of problem:
> > 
> > When creating new authentication key for cinder external provider,
> > Random uuid is not suppose to be generated.
> > This should prompt the already existing uuid in the system or blank field to
> > be filled.  
> Not sure this is correct. Daniel?

It's actually by design. A random UUID is just generated for the user convenience. The UUID can be overridden by the user (the text-box is editable), so the user could enter a pre-generated key if required. Hence, closing as notabug.
Comment 4 Daniel Erez 2015-11-04 11:52:08 EST
After discussing with Ori, it seems that it would be nice to add a tool-tip for explaining that the UUID is generated automatically (i.e. to avoid confusion - as it might appear as the UUID is being retrieved from Cinder config file).
Comment 5 Red Hat Bugzilla Rules Engine 2015-11-04 11:52:13 EST
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.
Comment 6 Eyal Shenitzky 2015-12-20 08:31:30 EST
 Verified with the following code:
------------------------------------------

rhevm-3.6.1.3-0.1.el6

tool-tip added.

Moving to VERIFIED!
Comment 7 Sandro Bonazzola 2015-12-22 08:28:23 EST
oVirt 3.6.1 has been released and bz verified, moving to closed current release
Comment 8 Tahlia Richardson 2016-07-13 00:56:00 EDT
Not really worth a release note, so I've cleared the doc text field and flag. I have updated the Cinder instructions in the Administration Guide to say that you can also enter an existing UUID to the UUID field.

Note You need to log in before you can comment on or make changes to this bug.