Bug 1273898 - JON CLI deleteEventsForContext has signature which does not match remote usage.
JON CLI deleteEventsForContext has signature which does not match remote usage.
Status: CLOSED WONTFIX
Product: JBoss Operations Network
Classification: JBoss
Component: CLI (Show other bugs)
JON 3.3.4
Unspecified Unspecified
unspecified Severity medium
: ---
: JON 3.3.6
Assigned To: Michael Burman
Mike Foley
:
: 1273900 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-10-21 09:22 EDT by Prachi
Modified: 2016-06-02 11:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-02 11:15:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prachi 2015-10-21 09:22:15 EDT
Description of problem:

JON CLI "deleteEventsForContext" has signature which does not match  remote usage.

it accepts EntytiContext and List<Integer> ids. This signature is not consistent with the rest of remote APIs.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

var criteria=EntityCriteria();
EventManager.findEventsByCriteria(criteria);
event= EventManager.findEventsByCriteria(criteria);
var eventDetail=event.get(0);
eventDetail.id                                                                                    
15554

EventManager.deleteEventsForContext(EntityContext.forResource(10003),15554);(not working)
EventManager.deleteEventsForContext(EntityContext.forResource(10003),eventDetail.id); (not working)

Actual results:


Expected results:

It should delete the events

Additional info:

deleteEventsForContext has unfortunately signature which does not match (enough) remote usage.

it accepts EntytiContext and List<Integer> ids. This signature is not consistent with the rest of remote APIs.

We can test like this:

var list = java.util.ArrayList()
list.add(new java.lang.Integer(10054))

EventManager.deleteEventsForContext(EntityContext.forResource(10003), list)


However, this is not user friendly which would accept int... ids etc.
Comment 1 Filip Brychta 2015-10-22 10:44:03 EDT
*** Bug 1273900 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.